summaryrefslogtreecommitdiff
path: root/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-45.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-22 11:16:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-22 11:16:57 +0100
commit92a9a3adda432ad2b7af58e08f5493ed6dc81196 (patch)
tree875f2d54382fdb68add8e3a92e44e49447be4a4b /sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-45.0.ebuild
parent67ff4e881df5f5a1482662d6aba4680f82d12197 (diff)
gentoo auto-resync : 22:09:2023 - 11:16:57
Diffstat (limited to 'sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-45.0.ebuild')
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-45.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-45.0.ebuild b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-45.0.ebuild
new file mode 100644
index 000000000000..34f142050691
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-45.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson systemd xdg
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="wayland X"
+
+# Newer-than-strictly-required xdg-desktop-portal dep for hang/slowness fixes
+# https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome/-/issues/74
+DEPEND="
+ dev-libs/glib:2
+ gnome-base/gnome-desktop:4=
+ >=gui-libs/libadwaita-1.2.0:1
+ media-libs/fontconfig
+ sys-apps/dbus
+ >=sys-apps/xdg-desktop-portal-1.17.0
+ >=sys-apps/xdg-desktop-portal-gtk-1.14.0
+ gui-libs/gtk:4[wayland?,X?]
+ X? ( x11-libs/libX11 )
+ wayland? ( dev-libs/wayland )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ wayland? ( dev-util/wayland-scanner )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ )
+
+ meson_src_configure
+}