summaryrefslogtreecommitdiff
path: root/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44_rc.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-14 00:16:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-14 00:16:43 +0000
commit55b20c97078ded20d0e7c6b3ef33d673c861d8b4 (patch)
tree92579cc158fd711b487e332cf87f87f3cf489d69 /sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44_rc.ebuild
parent8c9b482f4679667d7b439749d9a9c65d559d11b8 (diff)
gentoo auto-resync : 14:03:2023 - 00:16:42
Diffstat (limited to 'sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44_rc.ebuild')
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44_rc.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44_rc.ebuild b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44_rc.ebuild
new file mode 100644
index 000000000000..dc27622098d4
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44_rc.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson systemd xdg
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome"
+SRC_URI="https://download.gnome.org/sources/${PN}/44/${PN}-44.rc.tar.xz"
+S="${WORKDIR}/${PN}-44.rc"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="wayland X"
+
+DEPEND="
+ dev-libs/glib:2
+ gnome-base/gnome-desktop:4=
+ gui-libs/libadwaita:1
+ media-libs/fontconfig
+ sys-apps/dbus
+ >=sys-apps/xdg-desktop-portal-1.15.0
+ >=sys-apps/xdg-desktop-portal-gtk-1.14.0
+ gui-libs/gtk:4[wayland?,X?]
+ wayland? ( dev-libs/wayland )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ wayland? ( dev-util/wayland-scanner )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ )
+
+ meson_src_configure
+}