summaryrefslogtreecommitdiff
path: root/sys-apps/vbetool/vbetool-1.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-29 03:21:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-29 03:21:54 +0100
commit62ea91b40c7650011a72ed2443f76b88b06123fe (patch)
tree1e60e1f2ac4a793b10db166d55ffadb46eeda0ff /sys-apps/vbetool/vbetool-1.2.2.ebuild
parentbd7d7f7f69423122e08209eefb1a8fa1d363e35e (diff)
gentoo auto-resync : 29:09:2022 - 03:21:54
Diffstat (limited to 'sys-apps/vbetool/vbetool-1.2.2.ebuild')
-rw-r--r--sys-apps/vbetool/vbetool-1.2.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/vbetool/vbetool-1.2.2.ebuild b/sys-apps/vbetool/vbetool-1.2.2.ebuild
new file mode 100644
index 000000000000..9ad425b7bd53
--- /dev/null
+++ b/sys-apps/vbetool/vbetool-1.2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Run real-mode video BIOS code to alter hw state (i.e. reinitialize video card)"
+HOMEPAGE="https://cgit.freedesktop.org/~airlied/vbetool/"
+SRC_URI="https://dev.gentoo.org/~ionen/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/libx86
+ sys-libs/zlib:=
+ x11-libs/libpciaccess"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libx86.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}