summaryrefslogtreecommitdiff
path: root/sys-apps/uutils-coreutils/uutils-coreutils-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-25 00:12:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-25 00:12:20 +0100
commit996a2bda06cb164877d5d952774a6db1b271c2f3 (patch)
tree31930352b48fc7622d658ae37658c57ad9511ef6 /sys-apps/uutils-coreutils/uutils-coreutils-9999.ebuild
parent67e5603b2844a6657dd0438fa26626b013e5567f (diff)
gentoo auto-resync : 25:06:2024 - 00:12:20
Diffstat (limited to 'sys-apps/uutils-coreutils/uutils-coreutils-9999.ebuild')
-rw-r--r--sys-apps/uutils-coreutils/uutils-coreutils-9999.ebuild147
1 files changed, 89 insertions, 58 deletions
diff --git a/sys-apps/uutils-coreutils/uutils-coreutils-9999.ebuild b/sys-apps/uutils-coreutils/uutils-coreutils-9999.ebuild
index 54d71a2f8c9c..81d874fa698b 100644
--- a/sys-apps/uutils-coreutils/uutils-coreutils-9999.ebuild
+++ b/sys-apps/uutils-coreutils/uutils-coreutils-9999.ebuild
@@ -7,34 +7,40 @@ EAPI=8
CRATES="
adler@1.0.2
+ ahash@0.8.11
aho-corasick@1.0.4
+ allocator-api2@0.2.18
android-tzdata@0.1.1
android_system_properties@0.1.5
+ ansi-width@0.1.0
anstream@0.5.0
anstyle-parse@0.2.0
anstyle-query@1.0.0
anstyle-wincon@2.1.0
anstyle@1.0.0
+ arbitrary@1.3.2
arrayref@0.3.6
arrayvec@0.7.4
autocfg@1.1.0
- bigdecimal@0.4.0
+ bigdecimal@0.4.5
binary-heap-plus@0.5.0
- bindgen@0.63.0
+ bincode@1.3.3
+ bindgen@0.69.4
bitflags@1.3.2
- bitflags@2.4.2
+ bitflags@2.5.0
+ bitvec@1.0.1
blake2b_simd@1.0.2
blake3@1.5.1
block-buffer@0.10.3
bstr@1.9.1
bumpalo@3.11.1
- bytecount@0.6.7
+ bytecount@0.6.8
byteorder@1.5.0
cc@1.0.79
cexpr@0.6.0
cfg-if@1.0.0
cfg_aliases@0.1.1
- chrono@0.4.35
+ chrono@0.4.38
clang-sys@1.4.0
clap@4.4.2
clap_builder@4.4.2
@@ -47,7 +53,6 @@ CRATES="
const-random-macro@0.1.16
const-random@0.1.16
constant_time_eq@0.3.0
- conv@0.3.3
core-foundation-sys@0.8.3
coz@0.1.3
cpp@0.5.9
@@ -55,40 +60,45 @@ CRATES="
cpp_common@0.5.9
cpp_macros@0.5.9
cpufeatures@0.2.5
- crc32fast@1.3.2
+ crc32fast@1.4.0
crossbeam-channel@0.5.10
crossbeam-deque@0.8.4
crossbeam-epoch@0.9.17
- crossbeam-utils@0.8.18
+ crossbeam-utils@0.8.19
crossterm@0.27.0
crossterm_winapi@0.9.1
crunchy@0.2.2
crypto-common@0.1.6
ctrlc@3.4.4
- custom_derive@0.1.7
- data-encoding-macro-internal@0.1.12
- data-encoding-macro@0.1.14
- data-encoding@2.5.0
+ data-encoding-macro-internal@0.1.13
+ data-encoding-macro@0.1.15
+ data-encoding@2.6.0
+ deranged@0.3.11
+ derive_arbitrary@1.3.2
diff@0.1.13
digest@0.10.7
+ displaydoc@0.2.4
dlv-list@0.5.0
dns-lookup@2.0.4
dunce@1.0.4
either@1.8.0
encode_unicode@0.3.6
env_logger@0.8.4
+ equivalent@1.0.1
errno@0.3.8
exacl@0.12.0
fastrand@2.0.1
file_diff@1.0.0
+ filedescriptor@0.8.2
filetime@0.2.23
- flate2@1.0.24
+ flate2@1.0.28
fnv@1.0.7
fs_extra@1.3.0
fsevent-sys@4.1.0
- fts-sys@0.2.4
+ fts-sys@0.2.9
fundu-core@0.3.0
fundu@2.0.0
+ funty@2.0.0
futures-channel@0.3.28
futures-core@0.3.28
futures-executor@0.3.28
@@ -103,19 +113,22 @@ CRATES="
generic-array@0.14.6
getrandom@0.2.9
glob@0.3.1
- half@2.4.0
- hashbrown@0.13.2
+ half@2.4.1
+ hashbrown@0.14.3
hermit-abi@0.3.2
hex-literal@0.4.1
hex@0.4.3
- hostname@0.3.1
+ hostname@0.4.0
iana-time-zone-haiku@0.1.2
iana-time-zone@0.1.53
- indicatif@0.17.3
+ indexmap@2.2.6
+ indicatif@0.17.8
inotify-sys@0.1.5
inotify@0.9.6
+ instant@0.1.12
io-lifetimes@1.0.11
itertools@0.12.1
+ itertools@0.13.0
itoa@1.0.4
js-sys@0.3.64
keccak@0.1.4
@@ -123,39 +136,41 @@ CRATES="
kqueue@1.0.7
lazy_static@1.4.0
lazycell@1.3.0
- libc@0.2.153
+ libc@0.2.155
libloading@0.7.4
libm@0.2.7
linux-raw-sys@0.3.8
linux-raw-sys@0.4.12
lock_api@0.4.9
log@0.4.20
+ lru@0.12.3
lscolors@0.16.0
- match_cfg@0.1.0
md-5@0.10.6
- memchr@2.7.1
- memmap2@0.9.0
+ memchr@2.7.4
+ memmap2@0.9.4
minimal-lexical@0.2.1
- miniz_oxide@0.5.4
+ miniz_oxide@0.7.2
mio@0.8.11
nix@0.28.0
nom@7.1.3
notify@6.0.1
nu-ansi-term@0.49.0
- num-bigint@0.4.4
- num-integer@0.1.45
- num-traits@0.2.18
+ num-bigint@0.4.5
+ num-conv@0.1.0
+ num-integer@0.1.46
+ num-modular@0.5.1
+ num-prime@0.4.4
+ num-traits@0.2.19
num_threads@0.1.6
number_prefix@0.4.0
once_cell@1.19.0
onig@6.4.0
onig_sys@69.8.1
- ordered-multimap@0.6.0
+ ordered-multimap@0.7.3
os_display@0.1.3
parking_lot@0.12.1
parking_lot_core@0.9.9
- parse_datetime@0.5.0
- peeking_take_while@0.1.2
+ parse_datetime@0.6.0
phf@0.11.2
phf_codegen@0.11.2
phf_generator@0.11.1
@@ -163,82 +178,91 @@ CRATES="
pin-project-lite@0.2.9
pin-utils@0.1.0
pkg-config@0.3.26
- platform-info@2.0.2
- portable-atomic@0.3.15
+ platform-info@2.0.3
+ portable-atomic@1.6.0
+ powerfmt@0.2.0
ppv-lite86@0.2.17
pretty_assertions@1.4.0
- proc-macro2@1.0.63
+ prettyplease@0.2.19
+ proc-macro-crate@3.1.0
+ proc-macro2@1.0.86
procfs-core@0.16.0
procfs@0.16.0
quick-error@2.0.1
quickcheck@1.0.3
- quote@1.0.29
+ quote@1.0.36
+ radium@0.7.0
rand@0.8.5
rand_chacha@0.3.1
rand_core@0.6.4
rand_pcg@0.3.1
rayon-core@1.12.1
- rayon@1.9.0
+ rayon@1.10.0
redox_syscall@0.4.1
- redox_syscall@0.5.0
+ redox_syscall@0.5.2
reference-counted-singleton@0.1.2
regex-automata@0.4.4
regex-syntax@0.8.2
- regex@1.10.4
+ regex@1.10.5
relative-path@1.8.0
rlimit@0.10.1
roff@0.2.1
- rstest@0.18.2
- rstest_macros@0.18.2
- rust-ini@0.19.0
+ rstest@0.21.0
+ rstest_macros@0.21.0
+ rust-ini@0.21.0
rustc-hash@1.1.0
rustc_version@0.4.0
rustix@0.37.26
rustix@0.38.31
same-file@1.0.6
scopeguard@1.2.0
- self_cell@1.0.3
- selinux-sys@0.6.2
- selinux@0.4.0
+ self_cell@1.0.4
+ selinux-sys@0.6.9
+ selinux@0.4.4
semver@1.0.14
- serde@1.0.193
- serde_derive@1.0.193
+ serde-big-array@0.5.1
+ serde@1.0.203
+ serde_derive@1.0.203
sha1@0.10.6
sha2@0.10.8
sha3@0.10.8
shlex@1.3.0
signal-hook-mio@0.2.3
- signal-hook-registry@1.4.0
+ signal-hook-registry@1.4.1
signal-hook@0.3.17
siphasher@0.3.10
slab@0.4.7
sm3@0.4.2
- smallvec@1.13.1
+ smallvec@1.13.2
smawk@0.3.1
socket2@0.5.3
strsim@0.10.0
syn@1.0.109
- syn@2.0.32
+ syn@2.0.60
+ tap@1.0.1
tempfile@3.10.1
terminal_size@0.2.6
terminal_size@0.3.0
textwrap@0.16.1
- thiserror-impl@1.0.37
- thiserror@1.0.37
- time-core@0.1.0
- time-macros@0.2.8
- time@0.3.20
+ thiserror-impl@1.0.61
+ thiserror@1.0.61
+ time-core@0.1.2
+ time-macros@0.2.18
+ time@0.3.36
tiny-keccak@2.0.2
+ toml_datetime@0.6.6
+ toml_edit@0.21.1
+ trim-in-place@0.1.7
typenum@1.15.0
unicode-ident@1.0.5
unicode-linebreak@0.1.5
unicode-segmentation@1.11.0
- unicode-width@0.1.11
+ unicode-width@0.1.12
unicode-xid@0.2.4
- unindent@0.2.1
+ unindent@0.2.3
utf8parse@0.2.1
uuid@1.7.0
- uutils_term_grid@0.3.0
+ uutils_term_grid@0.6.0
version_check@0.9.4
walkdir@2.5.0
wasi@0.11.0+wasi-snapshot-preview1
@@ -250,15 +274,17 @@ CRATES="
which@4.3.0
wild@2.2.1
winapi-i686-pc-windows-gnu@0.4.0
- winapi-util@0.1.6
+ winapi-util@0.1.8
winapi-x86_64-pc-windows-gnu@0.4.0
winapi@0.3.9
+ windows-core@0.52.0
windows-sys@0.45.0
windows-sys@0.48.0
windows-sys@0.52.0
windows-targets@0.42.2
windows-targets@0.48.0
windows-targets@0.52.0
+ windows@0.52.0
windows_aarch64_gnullvm@0.42.2
windows_aarch64_gnullvm@0.48.0
windows_aarch64_gnullvm@0.52.0
@@ -280,10 +306,14 @@ CRATES="
windows_x86_64_msvc@0.42.2
windows_x86_64_msvc@0.48.0
windows_x86_64_msvc@0.52.0
+ winnow@0.5.40
+ wyz@0.5.1
xattr@1.3.1
yansi@0.5.1
z85@3.0.5
- zip@0.6.6
+ zerocopy-derive@0.7.33
+ zerocopy@0.7.33
+ zip@1.3.0
"
inherit cargo flag-o-matic
@@ -327,7 +357,8 @@ BDEPEND="
QA_FLAGS_IGNORED=".*"
PATCHES=(
- "${FILESDIR}"/${PN}-0.2.25-xfail-tests.patch
+ "${FILESDIR}"/${PN}-0.2.27-xfail-tests.patch
+ "${FILESDIR}"/${PN}-0.0.27-cow-tests.patch
)
src_unpack() {