summaryrefslogtreecommitdiff
path: root/sys-apps/util-linux/util-linux-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-07 13:16:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-07 13:16:39 +0100
commite91a1aaa5ec8fab37f0fd082ac6024d41c6651e2 (patch)
treeee7587dfd365faadd9b297d595c31368bf94f9ca /sys-apps/util-linux/util-linux-9999.ebuild
parent2d446203bcf1a0db08e99abca43513d246dfa73d (diff)
gentoo resync : 07.04.2018
Diffstat (limited to 'sys-apps/util-linux/util-linux-9999.ebuild')
-rw-r--r--sys-apps/util-linux/util-linux-9999.ebuild99
1 files changed, 58 insertions, 41 deletions
diff --git a/sys-apps/util-linux/util-linux-9999.ebuild b/sys-apps/util-linux/util-linux-9999.ebuild
index 6fcbc94b0787..76ee8160737a 100644
--- a/sys-apps/util-linux/util-linux-9999.ebuild
+++ b/sys-apps/util-linux/util-linux-9999.ebuild
@@ -25,7 +25,7 @@ HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/"
LICENSE="GPL-2 LGPL-2.1 BSD-4 MIT public-domain"
SLOT="0"
-IUSE="build caps +cramfs fdformat kill ncurses nls pam python +readline selinux slang static-libs +suid systemd test tty-helpers udev unicode"
+IUSE="build caps +cramfs fdformat kill ncurses nls pam python +readline selinux slang static-libs +suid systemd test tty-helpers udev unicode userland_GNU"
# Most lib deps here are related to programs rather than our libs,
# so we rarely need to specify ${MULTILIB_USEDEP}.
@@ -73,6 +73,13 @@ src_prepare() {
-e "s|UUIDD_SOCKET=\"\$(mktemp -u \"\${TS_OUTDIR}/uuiddXXXXXXXXXXXXX\")\"|UUIDD_SOCKET=\"\$(mktemp -u \"${T}/uuiddXXXXXXXXXXXXX.sock\")\"|g" \
tests/ts/uuid/uuidd || die "Failed to fix uuidd test"
+ if ! use userland_GNU; then
+ # test runner is using GNU-specific xargs call
+ sed -i -e 's:xargs:gxargs:' tests/run.sh || die
+ # test requires util-linux uuidgen (which we don't build)
+ rm tests/ts/uuid/oids || die
+ fi
+
if [[ ${PV} == 9999 ]] ; then
po/update-potfiles
eautoreconf
@@ -110,31 +117,11 @@ multilib_src_configure() {
export ac_cv_header_security_pam_appl_h=$(multilib_native_usex pam) #545042
local myeconfargs=(
- --disable-chfn-chsh
- --disable-login
- --disable-nologin
- --disable-su
- --docdir='${datarootdir}'/doc/${PF}
- --enable-agetty
- --enable-bash-completion
--enable-fs-paths-extra="${EPREFIX}/usr/sbin:${EPREFIX}/bin:${EPREFIX}/usr/bin"
- --enable-line
- --enable-partx
- --enable-raw
- --enable-rename
- --enable-rfkill
- --enable-schedutils
--with-bashcompletiondir="$(get_bashcompdir)"
- --with-systemdsystemunitdir=$(multilib_native_usex systemd "$(systemd_get_systemunitdir)" "no")
- $(multilib_native_use_enable caps setpriv)
- $(multilib_native_use_enable cramfs)
- $(multilib_native_use_enable fdformat)
$(multilib_native_use_enable nls)
$(multilib_native_use_enable suid makeinstall-chown)
$(multilib_native_use_enable suid makeinstall-setuid)
- $(multilib_native_use_enable tty-helpers mesg)
- $(multilib_native_use_enable tty-helpers wall)
- $(multilib_native_use_enable tty-helpers write)
$(multilib_native_use_with python)
$(multilib_native_use_with readline)
$(multilib_native_use_with slang)
@@ -144,39 +131,63 @@ multilib_src_configure() {
$(multilib_native_usex ncurses "$(use_with !unicode ncurses)" '--without-ncurses')
$(tc-has-tls || echo --disable-tls)
$(use_enable unicode widechar)
- $(use_enable kill)
$(use_enable static-libs static)
$(use_with selinux)
$(usex ncurses '' '--without-tinfo')
)
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_compile() {
- if multilib_is_native_abi; then
- default
+ # build programs only on GNU, on *BSD we want libraries only
+ if multilib_is_native_abi && use userland_GNU; then
+ myeconfargs+=(
+ --disable-chfn-chsh
+ --disable-login
+ --disable-nologin
+ --disable-su
+ --enable-agetty
+ --enable-bash-completion
+ --enable-line
+ --enable-partx
+ --enable-raw
+ --enable-rename
+ --enable-rfkill
+ --enable-schedutils
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ $(use_enable caps setpriv)
+ $(use_enable cramfs)
+ $(use_enable fdformat)
+ $(use_enable tty-helpers mesg)
+ $(use_enable tty-helpers wall)
+ $(use_enable tty-helpers write)
+ $(use_enable kill)
+ )
else
- # build libraries only
- emake -f Makefile -f - mylibs \
- <<< 'mylibs: $(usrlib_exec_LTLIBRARIES) $(pkgconfig_DATA)'
+ myeconfargs+=(
+ --disable-all-programs
+ --disable-bash-completion
+ --without-systemdsystemunitdir
+ # build libraries
+ --enable-libuuid
+ --enable-libblkid
+ --enable-libsmartcols
+ --enable-libfdisk
+ )
+ if use userland_GNU; then
+ # those libraries don't work on *BSD
+ myeconfargs+=(
+ --enable-libmount
+ )
+ fi
fi
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_test() {
- multilib_is_native_abi && emake check TS_OPTS="--parallel=$(makeopts_jobs) --nonroot"
+ emake check TS_OPTS="--parallel=$(makeopts_jobs) --nonroot"
}
multilib_src_install() {
- if multilib_is_native_abi; then
- default
- else
- emake DESTDIR="${D}" install-usrlib_execLTLIBRARIES \
- install-pkgconfigDATA install-uuidincHEADERS \
- install-nodist_blkidincHEADERS install-nodist_mountincHEADERS \
- install-nodist_smartcolsincHEADERS install-nodist_fdiskincHEADERS
- fi
+ emake DESTDIR="${D}" install
- if multilib_is_native_abi; then
+ if multilib_is_native_abi && use userland_GNU; then
# need the libs in /
gen_usr_ldscript -a blkid mount smartcols uuid
@@ -190,6 +201,12 @@ multilib_src_install_all() {
# e2fsprogs-libs didnt install .la files, and .pc work fine
find "${ED}" -name "*.la" -delete || die
+ if ! use userland_GNU; then
+ # manpage collisions
+ # TODO: figure out a good way to keep them
+ rm "${ED%/}"/usr/share/man/man3/uuid* || die
+ fi
+
if use pam; then
newpamd "${FILESDIR}/runuser.pamd" runuser
newpamd "${FILESDIR}/runuser-l.pamd" runuser-l