summaryrefslogtreecommitdiff
path: root/sys-apps/utempter/utempter-0.5.5.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /sys-apps/utempter/utempter-0.5.5.6-r1.ebuild
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'sys-apps/utempter/utempter-0.5.5.6-r1.ebuild')
-rw-r--r--sys-apps/utempter/utempter-0.5.5.6-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/utempter/utempter-0.5.5.6-r1.ebuild b/sys-apps/utempter/utempter-0.5.5.6-r1.ebuild
new file mode 100644
index 000000000000..f52de8c53368
--- /dev/null
+++ b/sys-apps/utempter/utempter-0.5.5.6-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="${P%.*}"
+MY_P="${MY_PN}-${PV##*.}"
+
+inherit flag-o-matic rpm toolchain-funcs
+
+DESCRIPTION="App that allows non-privileged apps to write utmp (login) info"
+HOMEPAGE="https://www.redhat.com/"
+SRC_URI="mirror://gentoo/${MY_P}.src.rpm"
+S="${WORKDIR}/${MY_PN}"
+
+LICENSE="|| ( MIT LGPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+BDEPEND="acct-group/utmp"
+RDEPEND="
+ ${BDEPEND}
+ !sys-libs/libutempter
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.5.6-no_utmpx.patch
+ "${FILESDIR}"/${PN}-0.5.5.6-fix-build-system.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+ append-cflags -Wall
+}
+
+src_install() {
+ local myemakeargs=(
+ LIBDIR="/usr/$(get_libdir)"
+ RPM_BUILD_ROOT="${ED}"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ dobin utmp
+
+ fowners root:utmp /usr/sbin/utempter
+ fperms 2755 /usr/sbin/utempter
+}