summaryrefslogtreecommitdiff
path: root/sys-apps/usbutils/usbutils-014-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /sys-apps/usbutils/usbutils-014-r1.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'sys-apps/usbutils/usbutils-014-r1.ebuild')
-rw-r--r--sys-apps/usbutils/usbutils-014-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/usbutils/usbutils-014-r1.ebuild b/sys-apps/usbutils/usbutils-014-r1.ebuild
new file mode 100644
index 000000000000..cee126405f8d
--- /dev/null
+++ b/sys-apps/usbutils/usbutils-014-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="USB enumeration utilities"
+HOMEPAGE="https://www.kernel.org/pub/linux/utils/usb/usbutils/
+ https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/usbutils.git/"
+SRC_URI="https://www.kernel.org/pub/linux/utils/usb/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="virtual/libusb:1=
+ virtual/libudev:="
+BDEPEND="
+ app-arch/xz-utils
+ virtual/pkgconfig
+ python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}
+ python? (
+ ${PYTHON_DEPS}
+ sys-apps/hwdata
+ )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+ use python && python_fix_shebang lsusb.py.in
+}
+
+src_configure() {
+ local myeconfargs=(
+ --datarootdir="${EPREFIX}/usr/share"
+ --datadir="${EPREFIX}/usr/share/hwdata"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ newdoc usbhid-dump/NEWS NEWS.usbhid-dump
+ dobin usbreset # noinst_PROGRAMS, but installed by other distros
+
+ if ! use python ; then
+ rm -f "${ED}"/usr/bin/lsusb.py || die
+ fi
+}