summaryrefslogtreecommitdiff
path: root/sys-apps/usbredir/usbredir-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/usbredir/usbredir-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/usbredir/usbredir-9999.ebuild')
-rw-r--r--sys-apps/usbredir/usbredir-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/usbredir/usbredir-9999.ebuild b/sys-apps/usbredir/usbredir-9999.ebuild
new file mode 100644
index 000000000000..8c8f43ddda02
--- /dev/null
+++ b/sys-apps/usbredir/usbredir-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic autotools git-r3
+
+DESCRIPTION="TCP daemon and set of libraries for usbredir protocol (redirecting USB traffic)"
+HOMEPAGE="https://www.spice-space.org/page/UsbRedir"
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/spice/usbredir.git"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE="static-libs"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="ChangeLog README* TODO *.txt"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # https://bugs.freedesktop.org/show_bug.cgi?id=54643
+ append-cflags -Wno-error
+
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ # noinst_PROGRAMS
+ dobin usbredirtestclient/usbredirtestclient
+}