summaryrefslogtreecommitdiff
path: root/sys-apps/tuned/tuned-2.22.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-07 00:08:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-07 00:08:01 +0100
commit941687623283212199cbe6e36f7d61b89d6222b2 (patch)
treeba7fb5198fd46b0b501a9c4362be2c26738408ad /sys-apps/tuned/tuned-2.22.0.ebuild
parent44cec61076bf2bbb3cea1fc89943dd6818a5acc5 (diff)
gentoo auto-resync : 07:06:2024 - 00:08:01
Diffstat (limited to 'sys-apps/tuned/tuned-2.22.0.ebuild')
-rw-r--r--sys-apps/tuned/tuned-2.22.0.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/sys-apps/tuned/tuned-2.22.0.ebuild b/sys-apps/tuned/tuned-2.22.0.ebuild
deleted file mode 100644
index 574731427297..000000000000
--- a/sys-apps/tuned/tuned-2.22.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit optfeature python-single-r1 tmpfiles xdg-utils
-
-DESCRIPTION="Daemon for monitoring and adaptive tuning of system devices"
-HOMEPAGE="https://github.com/redhat-performance/tuned"
-SRC_URI="https://github.com/redhat-performance/tuned/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/configobj[${PYTHON_USEDEP}]
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/python-linux-procfs[${PYTHON_USEDEP}]
- dev-python/pyudev[${PYTHON_USEDEP}]
- ')"
-
-RDEPEND="
- ${DEPEND}
- app-emulation/virt-what
- dev-debug/systemtap
- sys-apps/dbus
- sys-apps/ethtool
- sys-power/powertop
- "
-
-RESTRICT="test"
-
-src_prepare() {
- default
-
- sed -i \
- -e "/^PYTHON/s:/usr/bin/python3:${EPREFIX}/usr/bin/${EPYTHON}:" \
- -e "/^export DOCDIR/s/$/&\-\$(VERSION)/g" \
- -e "/\$(DESTDIR)\/run\/tuned/d" \
- -e "/\$(DESTDIR)\/var\/lib\/tuned/d" \
- -e "/\$(DESTDIR)\/var\/log\/tuned/d" \
- Makefile || die
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- python_fix_shebang "${D}"
- python_optimize
-}
-
-pkg_postinst() {
- tmpfiles_process ${PN}.conf
- xdg_icon_cache_update
-
- optfeature_header
- optfeature "Optimize for power saving by spinning-down rotational disks" sys-apps/hdparm
- optfeature "Get hardware info" sys-apps/dmidecode
- optfeature "Optimize network txqueuelen" sys-apps/iproute2
-}