summaryrefslogtreecommitdiff
path: root/sys-apps/toybox/toybox-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /sys-apps/toybox/toybox-9999.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'sys-apps/toybox/toybox-9999.ebuild')
-rw-r--r--sys-apps/toybox/toybox-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sys-apps/toybox/toybox-9999.ebuild b/sys-apps/toybox/toybox-9999.ebuild
index 888ca615d7a4..35f861185918 100644
--- a/sys-apps/toybox/toybox-9999.ebuild
+++ b/sys-apps/toybox/toybox-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit multiprocessing savedconfig toolchain-funcs
@@ -10,7 +10,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/landley/toybox.git"
else
SRC_URI="https://landley.net/code/toybox/downloads/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~x86"
fi
DESCRIPTION="Common linux commands in a multicall binary"
@@ -45,14 +45,14 @@ src_configure() {
src_compile() {
unset CROSS_COMPILE
export CPUS=$(makeopts_jobs)
- emake V=1
+ emake V=1 NOSTRIP=1
}
src_test() {
- emake test
+ emake V=1 tests
}
src_install() {
save_config .config
- newbin generated/unstripped/toybox toybox
+ dobin toybox
}