summaryrefslogtreecommitdiff
path: root/sys-apps/toybox/toybox-0.8.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /sys-apps/toybox/toybox-0.8.9.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'sys-apps/toybox/toybox-0.8.9.ebuild')
-rw-r--r--sys-apps/toybox/toybox-0.8.9.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sys-apps/toybox/toybox-0.8.9.ebuild b/sys-apps/toybox/toybox-0.8.9.ebuild
new file mode 100644
index 000000000000..2d47626cc148
--- /dev/null
+++ b/sys-apps/toybox/toybox-0.8.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing savedconfig toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/landley/toybox.git"
+else
+ SRC_URI="https://landley.net/code/toybox/downloads/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DESCRIPTION="Common linux commands in a multicall binary"
+HOMEPAGE="https://landley.net/code/toybox/"
+
+LICENSE="0BSD"
+SLOT="0"
+
+DEPEND="virtual/libcrypt:="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-verbose-build-fix.patch
+)
+
+src_prepare() {
+ default
+ restore_config .config
+}
+
+src_configure() {
+ tc-export CC STRIP
+ export HOSTCC="$(tc-getBUILD_CC)"
+ # Respect CFLAGS
+ export OPTIMIZE="${CFLAGS}"
+
+ if [[ -f .config ]]; then
+ yes "" | emake -j1 oldconfig > /dev/null
+ return 0
+ else
+ einfo "Could not locate user configfile, so we will save a default one"
+ emake -j1 defconfig > /dev/null
+ fi
+}
+
+src_compile() {
+ unset CROSS_COMPILE
+ export CPUS=$(makeopts_jobs)
+ emake V=1 NOSTRIP=1
+}
+
+src_test() {
+ emake V=1 tests
+}
+
+src_install() {
+ save_config .config
+ dobin toybox
+}