summaryrefslogtreecommitdiff
path: root/sys-apps/toybox/toybox-0.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sys-apps/toybox/toybox-0.8.0.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sys-apps/toybox/toybox-0.8.0.ebuild')
-rw-r--r--sys-apps/toybox/toybox-0.8.0.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/sys-apps/toybox/toybox-0.8.0.ebuild b/sys-apps/toybox/toybox-0.8.0.ebuild
deleted file mode 100644
index 564d2c54b23c..000000000000
--- a/sys-apps/toybox/toybox-0.8.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit multiprocessing savedconfig toolchain-funcs
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/landley/toybox.git"
-else
- SRC_URI="https://landley.net/code/toybox/downloads/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-# makefile is stupid
-RESTRICT="test"
-
-DESCRIPTION="Common linux commands in a multicall binary"
-HOMEPAGE="https://landley.net/code/toybox/"
-
-# The source code does not explicitly say that it's BSD, but the author has repeatedly said it
-LICENSE="BSD-2"
-SLOT="0"
-IUSE=""
-
-src_prepare() {
- default
- restore_config .config
-}
-
-src_configure() {
- if [ -f .config ]; then
- yes "" | emake -j1 oldconfig > /dev/null
- return 0
- else
- einfo "Could not locate user configfile, so we will save a default one"
- emake -j1 defconfig > /dev/null
- fi
-}
-
-src_compile() {
- tc-export CC STRIP
- export HOSTCC=$(tc-getBUILD_CC)
- unset CROSS_COMPILE
- export CPUS=$(makeopts_jobs)
- emake V=1
-}
-
-src_test() {
- emake test
-}
-
-src_install() {
- save_config .config
- newbin generated/unstripped/toybox toybox
-}