summaryrefslogtreecommitdiff
path: root/sys-apps/sysvinit/sysvinit-3.08.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-26 23:40:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-26 23:40:45 +0000
commite53a98716127eb7be20f46713a7442d5b8820633 (patch)
tree65a649f66422bc6677cae851cf42a166e45d2ced /sys-apps/sysvinit/sysvinit-3.08.ebuild
parentfab95e98818bada1626a7723a1348f4e920d25e0 (diff)
gentoo auto-resync : 26:02:2024 - 23:40:45
Diffstat (limited to 'sys-apps/sysvinit/sysvinit-3.08.ebuild')
-rw-r--r--sys-apps/sysvinit/sysvinit-3.08.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-apps/sysvinit/sysvinit-3.08.ebuild b/sys-apps/sysvinit/sysvinit-3.08.ebuild
index f5abf9ccf170..e0191c1ef4c4 100644
--- a/sys-apps/sysvinit/sysvinit-3.08.ebuild
+++ b/sys-apps/sysvinit/sysvinit-3.08.ebuild
@@ -141,7 +141,7 @@ src_compile() {
}
src_install() {
- emake -C src install ROOT="${D}"
+ emake -C src install ROOT="${ED}"
dodoc README doc/*
insinto /etc
@@ -173,7 +173,7 @@ pkg_postinst() {
# Reload init to fix unmounting problems of / on next reboot.
# This is really needed, as without the new version of init cause init
# not to quit properly on reboot, and causes a fsck of / on next reboot.
- if [[ -z ${ROOT} ]] ; then
+ if [[ -z ${EROOT} ]] ; then
if [[ -e /dev/initctl ]] && [[ ! -e /run/initctl ]] ; then
ln -s /dev/initctl /run/initctl \
|| ewarn "Failed to set /run/initctl symlink!"