summaryrefslogtreecommitdiff
path: root/sys-apps/systemd/systemd-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
commit89c6c06b8c42107dd231687a1012354e7d3039fc (patch)
treedad94f4da8a6694f3cb99f7048be2f9cf5f78f97 /sys-apps/systemd/systemd-9999.ebuild
parent796cae72cf9ed18ba01256ac1f83a686a2a76036 (diff)
gentoo resync : 26.11.2017
Diffstat (limited to 'sys-apps/systemd/systemd-9999.ebuild')
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild36
1 files changed, 11 insertions, 25 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 8256350c5e12..032a4e3441e3 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -20,11 +20,10 @@ HOMEPAGE="https://www.freedesktop.org/wiki/Software/systemd"
LICENSE="GPL-2 LGPL-2.1 MIT public-domain"
SLOT="0/2"
-IUSE="acl apparmor audit build cryptsetup curl elfutils +gcrypt gnuefi http
- idn importd +kmod libidn2 +lz4 lzma nat pam policykit
- qrcode +seccomp selinux ssl sysv-utils test vanilla xkb"
+IUSE="acl apparmor audit build cryptsetup curl elfutils +gcrypt gnuefi http idn importd +kmod libidn2 +lz4 lzma nat pam policykit qrcode +seccomp selinux ssl sysv-utils test usrmerge vanilla xkb"
REQUIRED_USE="importd? ( curl gcrypt lzma )"
+RESTRICT="!test? ( test )"
MINKV="3.11"
@@ -200,9 +199,8 @@ multilib_src_configure() {
-Dpamlibdir="$(getpam_mod_dir)"
# avoid bash-completion dep
-Dbashcompletiondir="$(get_bashcompdir)"
- # make sure we get /bin:/sbin in $PATH
- -Dsplit-usr=true
- -Drootprefix="${EPREFIX}${ROOTPREFIX}"
+ # make sure we get /bin:/sbin in PATH
+ -Dsplit-usr=$(usex usrmerge false true)
-Dsysvinit-path=
-Dsysvrcnd-path=
# no deps
@@ -299,10 +297,11 @@ multilib_src_install_all() {
dodoc "${FILESDIR}"/nsswitch.conf
if use sysv-utils; then
+ local app
for app in halt poweroff reboot runlevel shutdown telinit; do
- dosym "${EPREFIX}${ROOTPREFIX%/}/bin/systemctl" /sbin/${app}
+ dosym ../bin/systemctl /sbin/${app}
done
- dosym "${EPREFIX}${ROOTPREFIX%/}/lib/systemd/systemd" /sbin/init
+ dosym ../lib/systemd/systemd /sbin/init
else
# we just keep sysvinit tools, so no need for the mans
rm "${ED%/}"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 \
@@ -328,12 +327,12 @@ multilib_src_install_all() {
rm -fr "${ED%/}"/etc/systemd/system/sockets.target.wants || die
rm -fr "${ED%/}"/etc/systemd/system/sysinit.target.wants || die
- rm -r "${ED%/}${ROOTPREFIX%/}/lib/udev/hwdb.d" || die
+ rm -r "${ED%/}"/lib/udev/hwdb.d || die
- if [[ ! -e "${ED%/}"/usr/lib/systemd/systemd ]]; then
+ if ! use usrmerge; then
# Avoid breaking boot/reboot
- dosym "../../..${ROOTPREFIX%/}/lib/systemd/systemd" /usr/lib/systemd/systemd
- dosym "../../..${ROOTPREFIX%/}/lib/systemd/systemd-shutdown" /usr/lib/systemd/systemd-shutdown
+ dosym ../../../lib/systemd/systemd /usr/lib/systemd/systemd
+ dosym ../../../lib/systemd/systemd-shutdown /usr/lib/systemd/systemd-shutdown
fi
}
@@ -381,19 +380,6 @@ migrate_locale() {
fi
}
-pkg_preinst() {
- # If /lib/systemd and /usr/lib/systemd are the same directory, remove the
- # symlinks we created in src_install.
- if [[ $(realpath "${EROOT%/}${ROOTPREFIX}/lib/systemd") == $(realpath "${EROOT%/}/usr/lib/systemd") ]]; then
- if [[ -L ${ED%/}/usr/lib/systemd/systemd ]]; then
- rm "${ED%/}/usr/lib/systemd/systemd" || die
- fi
- if [[ -L ${ED%/}/usr/lib/systemd/systemd-shutdown ]]; then
- rm "${ED%/}/usr/lib/systemd/systemd-shutdown" || die
- fi
- fi
-}
-
pkg_postinst() {
newusergroup() {
enewgroup "$1"