summaryrefslogtreecommitdiff
path: root/sys-apps/systemd/systemd-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
commit1dde4e5c4b92d849bf1abf0a48135b2a0644f7e1 (patch)
treec99a472cce74148d499f42ada873454b0e32a42d /sys-apps/systemd/systemd-9999.ebuild
parentda6a52f691ef980bab92d003d5df8f463c623af8 (diff)
gentoo resync : 13.03.2018
Diffstat (limited to 'sys-apps/systemd/systemd-9999.ebuild')
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 60dd1f8efd11..6c34c1b92a00 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -300,17 +300,11 @@ multilib_src_install_all() {
einstalldocs
dodoc "${FILESDIR}"/nsswitch.conf
- if use sysv-utils; then
- local app
- for app in halt poweroff reboot runlevel shutdown telinit; do
- dosym ../bin/systemctl /sbin/${app}
- done
- dosym ../lib/systemd/systemd /sbin/init
- else
- # we just keep sysvinit tools, so no need for the mans
- rm "${ED%/}"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 \
- || die
+ if ! use sysv-utils; then
+ rm "${ED%/}"/sbin/{halt,init,poweroff,reboot,runlevel,shutdown,telinit} || die
+ rmdir "${ED%/}"/sbin || die
rm "${ED%/}"/usr/share/man/man1/init.1 || die
+ rm "${ED%/}"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 || die
fi
# Preserve empty dirs in /etc & /var, bug #437008