summaryrefslogtreecommitdiff
path: root/sys-apps/systemd-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-09 00:08:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-09 00:08:14 +0100
commit4fe228ee9aa3b9b825d54ace549a5517e153e8bd (patch)
tree90a261e3ea59b80722d70d3c42f3e40d16c9f8dd /sys-apps/systemd-utils
parentadc09cc4e6ebf7931735c02c0c272b4b885c2b30 (diff)
gentoo auto-resync : 09:06:2024 - 00:08:13
Diffstat (limited to 'sys-apps/systemd-utils')
-rw-r--r--sys-apps/systemd-utils/Manifest2
-rw-r--r--sys-apps/systemd-utils/systemd-utils-255.7-r1.ebuild32
2 files changed, 27 insertions, 7 deletions
diff --git a/sys-apps/systemd-utils/Manifest b/sys-apps/systemd-utils/Manifest
index 7b8972393eee..b264788d93bb 100644
--- a/sys-apps/systemd-utils/Manifest
+++ b/sys-apps/systemd-utils/Manifest
@@ -15,5 +15,5 @@ DIST systemd-stable-255.7.tar.gz 15068684 BLAKE2B 6fb5415d9e013bc8695ef837affce7
EBUILD systemd-utils-254.10-r1.ebuild 13355 BLAKE2B 9e88dd7b2bc7c280aa4430d9e4ec9bea942b365408c775d0e5a53ae9d6b1eee3f79bada47ac83f3f3b4bd0fa5245b3158fc48e4b5003ba15bb7c3eb9179c9bc2 SHA512 86199fe50859269f739b37d2fa6d345b17ad90edd0aefd203f3beafdfd36c79affb16a61546da919e984836fcaded2831bd406f7123b0a84ee50ef65ac4d8b5c
EBUILD systemd-utils-254.12.ebuild 13363 BLAKE2B 21cc042bc1041556b71f12c160a8fd5b23f31a9598d6a85b13b77ccd01b5b0e34350bde236f151662873734003fe2fd5a001c746370c16fb8308fb51e283d843 SHA512 9660bcde5c1a06aa03dd7bc90aad59421eeea53757ed1edc2d674c1cddc0addf6b7670520426bd569c5f3e309f66ab641362c260c1fbdfdd20fb10198032677a
EBUILD systemd-utils-254.13.ebuild 13356 BLAKE2B b4892ba9c9ab31ded67652533fabf4f36d5b76377ea14e5d145795bb45cbdcf300660f1a54abe61a050a3287c08309e8fadfcf5f4d17b0c4bc7640b5382499ba SHA512 c8d72fe488c33f75f3e9ff11fc885befed66b61f3dea70c1e367b91a037536bc7d4668983644048c1099e07ee0977203a8ea6908b89dbd27371f5b1e4ce1bbd1
-EBUILD systemd-utils-255.7-r1.ebuild 13700 BLAKE2B e5410d9a84a8a11fa26900d2f8bf95c7a955de574cb2bc3a7fe6cea3b15a130a2eee35ada345fd10ae8bed3d981d106db9458000893560810d4985fa1b9166c1 SHA512 34c573fbea37536d52e1c17030e299d227324b74155ebfca9166a5391c13d03734e718df27b634e9871d2c5bbcbce030671494094aa85472b327dab802c12c98
+EBUILD systemd-utils-255.7-r1.ebuild 14028 BLAKE2B b56059397502d4194998c983b2554a06d1414645d7121e9b9fb811201f903b22b13e4f9b5a01ed2cc92f5102f748d088f583526935104da83c2c2f0a85075249 SHA512 505e98845143c3f596d72f15ef39bb58785be4c43492616d570dd46b0252a18615e6b71ca7efae49255d5ae880422551bdbab948865407e67f9d866b5cb09b52
MISC metadata.xml 888 BLAKE2B b799e1d62a1208dbbec1a1cfb47592b069d5c79cb18efffef922c72b0d61e30938d26c6f4e0d3951f9c327601dd71de14062dad0a47e6b84a61b1a8b125f1a6b SHA512 6debd964f9c127ba4332e0c0b86e506d3cf10cbe3cd45442bf7955b16e790a9eccdd928d473b3722b11b4a75d34fe5bb91f4867a5dc92e786ba73d9ec3f54712
diff --git a/sys-apps/systemd-utils/systemd-utils-255.7-r1.ebuild b/sys-apps/systemd-utils/systemd-utils-255.7-r1.ebuild
index dbab6cb8489d..0d6be4c5b60d 100644
--- a/sys-apps/systemd-utils/systemd-utils-255.7-r1.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-255.7-r1.ebuild
@@ -6,8 +6,8 @@ PYTHON_COMPAT=( python3_{10..12} )
QA_PKGCONFIG_VERSION=$(ver_cut 1)
-inherit bash-completion-r1 flag-o-matic linux-info meson-multilib python-single-r1
-inherit secureboot udev
+inherit bash-completion-r1 flag-o-matic linux-info meson-multilib ninja-utils
+inherit python-single-r1 secureboot udev
DESCRIPTION="Utilities split out from systemd for OpenRC users"
HOMEPAGE="https://systemd.io/"
@@ -254,6 +254,17 @@ multilib_src_configure() {
fi
}
+have_dmi() {
+ # see dmi_arches in meson.build
+ case ${CHOST} in
+ mips64*)
+ return 1 ;;
+ aarch64*|arm*|ia64*|i?86*|loongarch64*|mips*|x86_64*)
+ return 0 ;;
+ esac
+ return 1
+}
+
multilib_src_compile() {
local targets=() optional_targets=()
if multilib_is_native_abi; then
@@ -327,7 +338,6 @@ multilib_src_compile() {
systemd-hwdb
ata_id
cdrom_id
- dmi_memory_id
fido_id
iocost
mtd_probe
@@ -357,7 +367,12 @@ multilib_src_compile() {
rules.d/50-udev-default.rules
rules.d/60-persistent-storage.rules
rules.d/64-btrfs.rules
+ # Needed for tests
+ rules.d/99-systemd.rules
)
+ if have_dmi; then
+ targets+=( dmi_memory_id )
+ fi
if use test; then
targets+=(
test-fido-id-desc
@@ -399,7 +414,7 @@ multilib_src_compile() {
meson_src_compile "${targets[@]}"
fi
if [[ ${#optional_targets[@]} -ne 0 ]]; then
- nonfatal meson_src_compile "${optional_targets[@]}"
+ ninja ${NINJAOPTS} "${optional_targets[@]}"
fi
}
@@ -473,8 +488,13 @@ multilib_src_install() {
dosym ../../bin/udevadm /usr/lib/systemd/systemd-udevd
exeinto /usr/lib/udev
- set_rpath {ata_id,cdrom_id,dmi_memory_id,fido_id,iocost,mtd_probe,scsi_id,v4l_id}
- doexe {ata_id,cdrom_id,dmi_memory_id,fido_id,iocost,mtd_probe,scsi_id,v4l_id}
+ set_rpath {ata_id,cdrom_id,fido_id,iocost,mtd_probe,scsi_id,v4l_id}
+ doexe {ata_id,cdrom_id,fido_id,iocost,mtd_probe,scsi_id,v4l_id}
+
+ if have_dmi; then
+ set_rpath dmi_memory_id
+ doexe dmi_memory_id
+ fi
rm -f rules.d/99-systemd.rules
insinto /usr/lib/udev/rules.d