summaryrefslogtreecommitdiff
path: root/sys-apps/systemd-utils/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-24 01:25:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-24 01:25:35 +0100
commita152c669e7ec3bb6ae13b747b985e2ece3b58b0a (patch)
treed0bc106af803b1687d9959980809b98a2419a2a7 /sys-apps/systemd-utils/files
parente61316437bd8569d122a22afee87973ea4949120 (diff)
gentoo auto-resync : 24:06:2023 - 01:25:35
Diffstat (limited to 'sys-apps/systemd-utils/files')
-rw-r--r--sys-apps/systemd-utils/files/systemd-utils-253.4-musl-lfs.patch52
1 files changed, 0 insertions, 52 deletions
diff --git a/sys-apps/systemd-utils/files/systemd-utils-253.4-musl-lfs.patch b/sys-apps/systemd-utils/files/systemd-utils-253.4-musl-lfs.patch
deleted file mode 100644
index 312232d0b3a5..000000000000
--- a/sys-apps/systemd-utils/files/systemd-utils-253.4-musl-lfs.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-https://github.com/systemd/systemd/pull/27599
-
-From d096e05c625ea825eb4d781216ded717b7f71cca Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Wed, 10 May 2023 01:47:13 +0100
-Subject: [PATCH] dirent: conditionalize dirent assert based on dirent64
- existence
-
->=musl-1.2.4 doesn't define dirent64 and its LFS friends as its "native"
-functions are already LFS-aware.
-
-Check for dirent64 in meson.build and only assert if it exists.
-
-Bug: https://bugs.gentoo.org/905900
-Closes: https://github.com/systemd/systemd/pull/25809
---- a/meson.build
-+++ b/meson.build
-@@ -544,6 +544,7 @@ assert(long_max > 100000)
- conf.set_quoted('LONG_MAX_STR', '@0@'.format(long_max))
-
- decl_headers = '''
-+#include <dirent.h>
- #include <uchar.h>
- #include <sys/mount.h>
- #include <sys/stat.h>
-@@ -553,6 +554,7 @@ foreach decl : ['char16_t',
- 'char32_t',
- 'struct mount_attr',
- 'struct statx',
-+ 'struct dirent64',
- ]
-
- # We get -1 if the size cannot be determined
---- a/src/basic/dirent-util.h
-+++ b/src/basic/dirent-util.h
-@@ -36,6 +36,7 @@ struct dirent *readdir_no_dot(DIR *dirp);
- /* Only if 64bit off_t is enabled struct dirent + struct dirent64 are actually the same. We require this, and
- * we want them to be interchangeable to make getdents64() work, hence verify that. */
- assert_cc(_FILE_OFFSET_BITS == 64);
-+#if HAVE_STRUCT_DIRENT64
- assert_cc(sizeof(struct dirent) == sizeof(struct dirent64));
- assert_cc(offsetof(struct dirent, d_ino) == offsetof(struct dirent64, d_ino));
- assert_cc(sizeof_field(struct dirent, d_ino) == sizeof_field(struct dirent64, d_ino));
-@@ -47,6 +48,7 @@ assert_cc(offsetof(struct dirent, d_type) == offsetof(struct dirent64, d_type));
- assert_cc(sizeof_field(struct dirent, d_type) == sizeof_field(struct dirent64, d_type));
- assert_cc(offsetof(struct dirent, d_name) == offsetof(struct dirent64, d_name));
- assert_cc(sizeof_field(struct dirent, d_name) == sizeof_field(struct dirent64, d_name));
-+#endif
-
- #define FOREACH_DIRENT_IN_BUFFER(de, buf, sz) \
- for (void *_end = (uint8_t*) ({ (de) = (buf); }) + (sz); \
-