summaryrefslogtreecommitdiff
path: root/sys-apps/systemd-readahead
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
commit586819755b4dbfdffdc8a725ab7c0f86095b8489 (patch)
treed6790c838cfe9607c996e4913fdf11bad5fdd528 /sys-apps/systemd-readahead
parent3f71901f8c228f4de570abed1831ce3ee425343e (diff)
gentoo resync : 15.09.2018
Diffstat (limited to 'sys-apps/systemd-readahead')
-rw-r--r--sys-apps/systemd-readahead/Manifest2
-rw-r--r--sys-apps/systemd-readahead/systemd-readahead-216.ebuild14
2 files changed, 12 insertions, 4 deletions
diff --git a/sys-apps/systemd-readahead/Manifest b/sys-apps/systemd-readahead/Manifest
index c50c35f4ccbb..6c725ddf48af 100644
--- a/sys-apps/systemd-readahead/Manifest
+++ b/sys-apps/systemd-readahead/Manifest
@@ -1,4 +1,4 @@
AUX systemd-readahead-216-sysmacros.patch 1814 BLAKE2B 74dc5ed9bd5bc1947889c8f7a7e5574322ee8bf2bdee3cd068cbb3a453eae09cf13500757608b4e6b4a24d012a9c7af3f67e444b6ea68ff4dc2b3b658e062b1e SHA512 e48c013913b4db636f070d045eb65dff193d0b5cd25a0d1c98ed62b4071bc6925dce7c835341122fd6e0dc3136d11a8fa4ed35332a8b44ffb6f13195db9d6763
DIST systemd-216.tar.xz 3612960 BLAKE2B 677fa79e7a8dae5d62f37115c3087d89c46a28515c1fe48abbd77016ee41565583e407913b5a9738908436a2ccc36a1d3305392d8dfa5ac053a44ca66d587611 SHA512 f4eee6664368168eafd61939f1355ac21c7eeecce6247de98ef36f40bb6a942d12c006ced4ee15f3d8f11699c194990222d5a5115b45f2aa81f2a1abafebbdd2
-EBUILD systemd-readahead-216.ebuild 4306 BLAKE2B 676cf7b52273b8a4d464a3d8b0ac8ce324901e8ea3ea62bb1c7e2a95e183a46d5c5d7d6f89ef7d7f1c6817421130282aaad2698f0b63eff46d4c9fe6840a08ec SHA512 b7ce0255c5620821294ae1781fe5ea38993edd6b32fa55a0dda33be87170d7611064a684a6ae1824e18fa50f7c60a10eff19dfbeb4ddad73cc1888c1dfe3a167
+EBUILD systemd-readahead-216.ebuild 4873 BLAKE2B 44a79597767759f87831c3cdbfe50b20764af32361b1a09eb973709cdcbd896508cb79f107153c9320b739ad6f13e73a33b1236f8e7fe7a1b0a96e1db630f93d SHA512 7953f2d2b213ccf6685b46d5377887fd621fb1f751ab2d54525b192be10f785033989e99f5936b57af1fa4d6f923396b65a80477779faf8116f65b88c7b28339
MISC metadata.xml 243 BLAKE2B f40c5d69470d5136cba32e1ea6b2351ca1842a5d83381e0bef3e063e266c64bebb9ba85e1f155010e219b136c2827c989d9adf3b2c6b2f6ca265f03339c9a7ce SHA512 640630eb9d42c319ca1da37b03a03677a3dd4e48f28ce2690b64f6e4e7d5885cfda41d439f3f9d8b009be04891b043a5b0ac6f9d43b701f65c8fcc0e0613b04a
diff --git a/sys-apps/systemd-readahead/systemd-readahead-216.ebuild b/sys-apps/systemd-readahead/systemd-readahead-216.ebuild
index e256882d9165..a7580f0a561f 100644
--- a/sys-apps/systemd-readahead/systemd-readahead-216.ebuild
+++ b/sys-apps/systemd-readahead/systemd-readahead-216.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -135,8 +135,16 @@ src_configure() {
}
src_compile() {
- echo 'BUILT_SOURCES: $(BUILT_SOURCES)' > "${T}"/Makefile.extra
- emake -f Makefile -f "${T}"/Makefile.extra BUILT_SOURCES
+ echo 'BUILT_SOURCES: $(BUILT_SOURCES)' > ./Makefile.extra
+ emake -f Makefile -f ./Makefile.extra BUILT_SOURCES
+
+ # Fix compilation, bug #607068
+ # From comments at https://aur.archlinux.org/packages/systemd-readahead
+ gperf < src/libsystemd/sd-bus/bus-error-mapping.gperf > src/libsystemd/sd-bus/bus-error-mapping.c || die
+ sed -i -e "/bus_error_mapping_lookup/s/size_t/unsigned int/" src/libsystemd/sd-bus/bus-error-mapping.c || die
+ sed -i -e "/lookup_errno/s/size_t/unsigned int/" src/shared/errno-from-name.h || die
+ sed -i -e "/lookup_af/s/size_t/unsigned int/" src/shared/af-from-name.h || die
+ sed -i -e "/lookup_arphrd/s/size_t/unsigned int/" src/shared/arphrd-from-name.h || die
emake systemd-readahead
emake units/systemd-readahead-{drop,collect,replay,done}.service units/systemd-readahead-done.timer