summaryrefslogtreecommitdiff
path: root/sys-apps/system-monitoring-center/system-monitoring-center-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-03 10:05:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-03 10:05:34 +0100
commit0eb9883b5a8a53c253c98d1c77438c39c27c8c97 (patch)
tree47a89f252688f21fcacd066ac01ed1992a453d42 /sys-apps/system-monitoring-center/system-monitoring-center-9999.ebuild
parentc6872c361190d4f1a559d23458f6cdffb154b0b0 (diff)
gentoo auto-resync : 03:07:2023 - 10:05:34
Diffstat (limited to 'sys-apps/system-monitoring-center/system-monitoring-center-9999.ebuild')
-rw-r--r--sys-apps/system-monitoring-center/system-monitoring-center-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/system-monitoring-center/system-monitoring-center-9999.ebuild b/sys-apps/system-monitoring-center/system-monitoring-center-9999.ebuild
new file mode 100644
index 000000000000..76cc6a9cbef0
--- /dev/null
+++ b/sys-apps/system-monitoring-center/system-monitoring-center-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit meson python-single-r1 xdg
+
+DESCRIPTION="Multi-featured system monitor GUI written in Python"
+HOMEPAGE="https://github.com/hakandundar34coding/system-monitoring-center/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hakandundar34coding/${PN}.git"
+else
+ SRC_URI="https://github.com/hakandundar34coding/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gui-libs/gtk:4[introspection]
+ sys-apps/dmidecode
+ sys-apps/hwdata
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ meson_src_install
+ python_optimize "${ED}"/usr/share/${PN}
+
+ mv "${ED}"/usr/share/appdata "${ED}"/usr/share/metainfo || die
+}