summaryrefslogtreecommitdiff
path: root/sys-apps/syslog-notify/syslog-notify-0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/syslog-notify/syslog-notify-0.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/syslog-notify/syslog-notify-0.2.ebuild')
-rw-r--r--sys-apps/syslog-notify/syslog-notify-0.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/syslog-notify/syslog-notify-0.2.ebuild b/sys-apps/syslog-notify/syslog-notify-0.2.ebuild
new file mode 100644
index 000000000000..5f14dfa50ea5
--- /dev/null
+++ b/sys-apps/syslog-notify/syslog-notify-0.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit readme.gentoo
+
+DESCRIPTION="Notifications for syslog entries via libnotify"
+HOMEPAGE="https://jtniehof.github.com/syslog-notify/"
+SRC_URI="mirror://github/jtniehof/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=x11-libs/libnotify-0.7"
+RDEPEND="${DEPEND}
+ || ( app-admin/syslog-ng app-admin/rsyslog )"
+
+pkg_setup() {
+ DOCS="AUTHORS CHANGELOG HACKING README"
+ DISABLE_AUTOFORMATTING="yes"
+ DOC_CONTENTS="Add the following options on your /etc/syslog-ng/syslog-ng.conf
+file:
+# destination notify { pipe("/var/spool/syslog-notify"); };
+# log { source(src); destination(notify);};
+
+Remember to restart syslog-ng before starting syslog-notify."
+}
+
+src_install() {
+ default
+ dodir /var/spool
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ mkfifo "${EROOT}"/var/spool/syslog-notify
+ readme.gentoo_print_elog
+}