summaryrefslogtreecommitdiff
path: root/sys-apps/sydbox/sydbox-1.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/sydbox/sydbox-1.0.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/sydbox/sydbox-1.0.7.ebuild')
-rw-r--r--sys-apps/sydbox/sydbox-1.0.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/sydbox/sydbox-1.0.7.ebuild b/sys-apps/sydbox/sydbox-1.0.7.ebuild
new file mode 100644
index 000000000000..660422f3a516
--- /dev/null
+++ b/sys-apps/sydbox/sydbox-1.0.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="ptrace-based sandbox"
+HOMEPAGE="https://git.exherbo.org/sydbox-1.git"
+SRC_URI="http://distfiles.exherbo.org/distfiles/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug seccomp test"
+
+RDEPEND="sys-libs/pinktrace:=
+ debug? ( sys-libs/libunwind:= )"
+DEPEND="${RDEPEND}
+ test? ( app-portage/unsandbox )"
+
+src_configure() {
+ local myconf=(
+ $(use_enable debug)
+ $(use_enable seccomp)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ # two sandboxes are never a good idea ;-)
+ unsandbox emake check
+}