summaryrefslogtreecommitdiff
path: root/sys-apps/smartmontools/smartmontools-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /sys-apps/smartmontools/smartmontools-9999.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'sys-apps/smartmontools/smartmontools-9999.ebuild')
-rw-r--r--sys-apps/smartmontools/smartmontools-9999.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/sys-apps/smartmontools/smartmontools-9999.ebuild b/sys-apps/smartmontools/smartmontools-9999.ebuild
index 1c0502087af3..9772d6259993 100644
--- a/sys-apps/smartmontools/smartmontools-9999.ebuild
+++ b/sys-apps/smartmontools/smartmontools-9999.ebuild
@@ -3,14 +3,14 @@
EAPI=7
-inherit autotools flag-o-matic systemd
-if [[ ${PV} == "9999" ]] ; then
+inherit flag-o-matic systemd
+if [[ ${PV} == 9999 ]] ; then
ESVN_REPO_URI="https://svn.code.sf.net/p/smartmontools/code/trunk/smartmontools"
ESVN_PROJECT="smartmontools"
- inherit subversion
+ inherit autotools subversion
else
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
fi
DESCRIPTION="Tools to monitor storage systems to provide advanced warning of disk degradation"
@@ -52,7 +52,10 @@ REQUIRED_USE="(
src_prepare() {
default
- eautoreconf
+
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
}
src_configure() {