summaryrefslogtreecommitdiff
path: root/sys-apps/smartmontools/smartmontools-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /sys-apps/smartmontools/smartmontools-9999.ebuild
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'sys-apps/smartmontools/smartmontools-9999.ebuild')
-rw-r--r--sys-apps/smartmontools/smartmontools-9999.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/sys-apps/smartmontools/smartmontools-9999.ebuild b/sys-apps/smartmontools/smartmontools-9999.ebuild
index a2e1ad35a308..46b1cf2cff3f 100644
--- a/sys-apps/smartmontools/smartmontools-9999.ebuild
+++ b/sys-apps/smartmontools/smartmontools-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="6"
inherit autotools flag-o-matic systemd
if [[ ${PV} == "9999" ]] ; then
@@ -18,7 +18,7 @@ HOMEPAGE="https://www.smartmontools.org"
LICENSE="GPL-2"
SLOT="0"
-IUSE="caps +daemon selinux static update_drivedb"
+IUSE="caps +daemon selinux static systemd update_drivedb"
DEPEND="
caps? (
@@ -34,6 +34,7 @@ DEPEND="
RDEPEND="${DEPEND}
daemon? ( virtual/mailx )
selinux? ( sec-policy/selinux-smartmon )
+ systemd? ( sys-apps/systemd )
update_drivedb? (
app-crypt/gnupg
|| (
@@ -49,7 +50,6 @@ REQUIRED_USE="( caps? ( daemon ) )"
src_prepare() {
default
-
eautoreconf
}
@@ -58,14 +58,15 @@ src_configure() {
# The build installs /etc/init.d/smartd, but we clobber it
# in our src_install, so no need to manually delete it.
myeconfargs=(
- --docdir="${EPREFIX}/usr/share/doc/${PF}"
--with-drivedbdir="${EPREFIX}/var/db/${PN}" #575292
--with-initscriptdir="${EPREFIX}/etc/init.d"
+ #--with-smartdscriptdir="${EPREFIX}/usr/share/${PN}"
$(use_with caps libcap-ng)
$(use_with selinux)
- --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ $(use_with systemd libsystemd)
$(use_with update_drivedb gnupg)
$(use_with update_drivedb update-smart-drivedb)
+ $(usex systemd "--with-systemdsystemunitdir=$(systemd_get_systemunitdir)" '')
)
econf "${myeconfargs[@]}"
}