summaryrefslogtreecommitdiff
path: root/sys-apps/setserial/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/setserial/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/setserial/files')
-rw-r--r--sys-apps/setserial/files/serial-2.17-r422
-rw-r--r--sys-apps/setserial/files/setserial-2.17-build.patch11
-rw-r--r--sys-apps/setserial/files/setserial-2.17-darwin.patch33
-rw-r--r--sys-apps/setserial/files/setserial-2.17-hayes-esp.patch15
-rw-r--r--sys-apps/setserial/files/setserial-2.17-headers.patch12
-rw-r--r--sys-apps/setserial/files/setserial-2.17-manpage-updates.patch36
-rw-r--r--sys-apps/setserial/files/setserial-2.17-spelling.patch7
7 files changed, 136 insertions, 0 deletions
diff --git a/sys-apps/setserial/files/serial-2.17-r4 b/sys-apps/setserial/files/serial-2.17-r4
new file mode 100644
index 000000000000..fca37d67a480
--- /dev/null
+++ b/sys-apps/setserial/files/serial-2.17-r4
@@ -0,0 +1,22 @@
+#!/sbin/openrc-run
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+start() {
+ [ ! -e /etc/serial.conf ] && return 0
+
+ grep -v "^#\|^ \|^$\|^stty" /etc/serial.conf | while read device args
+ do
+ ebegin "Setting ${device} to $args"
+ setserial -b ${device} ${args}
+ eend $?
+ done
+ grep "^stty" /etc/serial.conf | while read x device args
+ do
+ ebegin "Setting (stty) ${device} to $args"
+ stty -F ${device} ${args}
+ eend $?
+ done
+
+ return 0
+}
diff --git a/sys-apps/setserial/files/setserial-2.17-build.patch b/sys-apps/setserial/files/setserial-2.17-build.patch
new file mode 100644
index 000000000000..7e7ea25c8a06
--- /dev/null
+++ b/sys-apps/setserial/files/setserial-2.17-build.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -20,7 +20,7 @@
+ all: setserial setserial.cat
+
+ setserial: setserial.c
+- $(CC) $(CFLAGS) $(DEFS) $(INCS) setserial.c -o setserial
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(DEFS) $(INCS) setserial.c -o setserial
+
+ setserial.cat: setserial.8
+ nroff -man setserial.8 > setserial.cat
diff --git a/sys-apps/setserial/files/setserial-2.17-darwin.patch b/sys-apps/setserial/files/setserial-2.17-darwin.patch
new file mode 100644
index 000000000000..681f793383cd
--- /dev/null
+++ b/sys-apps/setserial/files/setserial-2.17-darwin.patch
@@ -0,0 +1,33 @@
+https://541536.bugs.gentoo.org/attachment.cgi?id=397618
+https://bugs.gentoo.org/show_bug.cgi?id=541536
+
+diff --git a/setserial.c b/setserial.c
+index 3474402..3ce8009 100644
+--- a/setserial.c
++++ b/setserial.c
+@@ -31,6 +31,25 @@
+
+ #include "version.h"
+
++#ifdef __APPLE__
++// see http://www.insanelymac.com/forum/topic/155999-compiling-setserial-on-mac-os-x/
++#ifndef TIOCGSERIAL
++#define TIOCGSERIAL 0x541E
++#endif
++#ifndef TIOCSERCONFIG
++#define TIOCSERCONFIG 0x5453
++#endif
++#ifndef TIOCSSERIAL
++#define TIOCSSERIAL 0x541F
++#endif
++#ifndef TIOCSERGWILD
++#define TIOCSERGWILD 0x5454
++#endif
++#ifndef TIOCSERSWILD
++#define TIOCSERSWILD 0x5455
++#endif
++#endif
++
+ static char version_str[] = "setserial version " SETSERIAL_VERSION ", "
+ SETSERIAL_DATE;
+
diff --git a/sys-apps/setserial/files/setserial-2.17-hayes-esp.patch b/sys-apps/setserial/files/setserial-2.17-hayes-esp.patch
new file mode 100644
index 000000000000..72783553c214
--- /dev/null
+++ b/sys-apps/setserial/files/setserial-2.17-hayes-esp.patch
@@ -0,0 +1,15 @@
+recent versions of linux have dropped the hayes esp driver
+
+http://bugs.gentoo.org/309883
+
+--- a/setserial.c
++++ b/setserial.c
+@@ -21,6 +21,8 @@
+ #endif
+ #ifdef HAVE_LINUX_HAYESESP_H
+ #include <linux/hayesesp.h>
++#else
++#undef TIOCGHAYESESP
+ #endif
+ #include <linux/serial.h>
+
diff --git a/sys-apps/setserial/files/setserial-2.17-headers.patch b/sys-apps/setserial/files/setserial-2.17-headers.patch
new file mode 100644
index 000000000000..f8aed4c4862c
--- /dev/null
+++ b/sys-apps/setserial/files/setserial-2.17-headers.patch
@@ -0,0 +1,12 @@
+--- a/setserial.c
++++ b/setserial.c
+@@ -15,6 +15,9 @@
+ #include <termios.h>
+ #include <string.h>
+ #include <errno.h>
++#include <stdlib.h>
++#include <unistd.h>
++#include <sys/ioctl.h>
+
+ #ifdef HAVE_ASM_IOCTLS_H
+ #include <asm/ioctls.h>
diff --git a/sys-apps/setserial/files/setserial-2.17-manpage-updates.patch b/sys-apps/setserial/files/setserial-2.17-manpage-updates.patch
new file mode 100644
index 000000000000..3e6b7f016197
--- /dev/null
+++ b/sys-apps/setserial/files/setserial-2.17-manpage-updates.patch
@@ -0,0 +1,36 @@
+--- a/setserial.8.in
++++ b/setserial.8.in
+@@ -34,7 +34,7 @@
+ program should be used. Typically it is called from an
+-.I rc.serial
++.I serial
+ script, which is usually run out of
+-.IR /etc/rc.local .
++.IR /etc/init.d/ .
+
+ The
+ .I device
+@@ -78,7 +78,7 @@
+ .B \-b
+ When reporting the configuration of a serial device, print a summary
+ of the device's configuration, which might be suitable for printing
+-during the bootup process, during the /etc/rc script.
++during the bootup process, in the /etc/init.d/serial script.
+ .TP
+ .B \-G
+ Print out the configuration information of the serial port in a form which
+@@ -504,12 +504,9 @@
+ CAUTION: Configuring a serial port to use an incorrect I/O port
+ can lock up your machine.
+ .SH FILES
+-.BR /etc/rc.local
+-.BR /etc/rc.serial
++.BR /etc/serial.conf
+ .SH "SEE ALSO"
+-.BR tty (4),
+-.BR ttys (4),
+-kernel/chr_drv/serial.c
++.BR tty (4)
+ .SH AUTHOR
+ The original version of setserial was written by Rick Sladkey
+ (jrs@world.std.com), and was modified by Michael K. Johnson
diff --git a/sys-apps/setserial/files/setserial-2.17-spelling.patch b/sys-apps/setserial/files/setserial-2.17-spelling.patch
new file mode 100644
index 000000000000..5275d4fa44c4
--- /dev/null
+++ b/sys-apps/setserial/files/setserial-2.17-spelling.patch
@@ -0,0 +1,7 @@
+Ripped from Fedora.
+
+--- a/setserial.c
++++ b/setserial.c
+@@ -710,1 +710,1 @@
+- fprintf(stderr, "\t spd_normal\tuse 38.4kb when a buad rate of 38.4kb is selected\n");
++ fprintf(stderr, "\t spd_normal\tuse 38.4kb when a baud rate of 38.4kb is selected\n");