summaryrefslogtreecommitdiff
path: root/sys-apps/selinux-python/selinux-python-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /sys-apps/selinux-python/selinux-python-9999.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'sys-apps/selinux-python/selinux-python-9999.ebuild')
-rw-r--r--sys-apps/selinux-python/selinux-python-9999.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/sys-apps/selinux-python/selinux-python-9999.ebuild b/sys-apps/selinux-python/selinux-python-9999.ebuild
index c1e6a49cf4c2..73a4652fbf63 100644
--- a/sys-apps/selinux-python/selinux-python-9999.ebuild
+++ b/sys-apps/selinux-python/selinux-python-9999.ebuild
@@ -9,12 +9,12 @@ inherit python-r1 toolchain-funcs
MY_P="${P//_/-}"
-MY_RELEASEDATE="20170804"
+MY_RELEASEDATE="20180426"
SEPOL_VER="${PV}"
SELNX_VER="${PV}"
SEMNG_VER="${PV}"
-IUSE="audit pam dbus"
+IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DESCRIPTION="SELinux core utilities"
@@ -26,7 +26,7 @@ if [[ ${PV} == 9999 ]] ; then
S="${WORKDIR}/${MY_P}/${PN#selinux-}"
else
SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ KEYWORDS="~amd64 ~arm64 ~mips ~x86"
S="${WORKDIR}/${MY_P}"
fi
@@ -54,7 +54,6 @@ src_compile() {
building() {
emake -C "${BUILD_DIR}" \
CC="$(tc-getCC)" \
- PYLIBVER="${EPYTHON}" \
LIBDIR="\$(PREFIX)/$(get_libdir)"
}
python_foreach_impl building
@@ -65,7 +64,6 @@ src_install() {
emake -C "${BUILD_DIR}" \
DESTDIR="${D}" \
LIBDIR="\$(PREFIX)/$(get_libdir)" \
- LIBSEPOLA="/usr/$(get_libdir)/libsepol.a" \
install
python_optimize
}
@@ -73,10 +71,10 @@ src_install() {
# Set version-specific scripts
for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
- python_replicate_script "${ED}/usr/bin/${pyscript}"
+ python_replicate_script "${ED}/usr/bin/${pyscript}"
done
for pyscript in semanage; do
- python_replicate_script "${ED}/usr/sbin/${pyscript}"
+ python_replicate_script "${ED}/usr/sbin/${pyscript}"
done
# Create sepolgen.conf with different devel location definition