summaryrefslogtreecommitdiff
path: root/sys-apps/sed/sed-4.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-15 10:03:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-15 10:03:16 +0100
commitd57892fd8c8d84b85e73005a433f66d85da12fa3 (patch)
tree6f735debac848918a243f90ae2fa6a2fb69e77ad /sys-apps/sed/sed-4.9.ebuild
parent4a7e8a04f36caa88d1996b1dcdedb196bb4beb2f (diff)
gentoo auto-resync : 15:05:2023 - 10:03:16
Diffstat (limited to 'sys-apps/sed/sed-4.9.ebuild')
-rw-r--r--sys-apps/sed/sed-4.9.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/sys-apps/sed/sed-4.9.ebuild b/sys-apps/sed/sed-4.9.ebuild
index 9eca0e443be2..c6cc11898175 100644
--- a/sys-apps/sed/sed-4.9.ebuild
+++ b/sys-apps/sed/sed-4.9.ebuild
@@ -47,6 +47,13 @@ src_configure() {
econf "${myconf[@]}"
}
+src_test() {
+ # We don't want to automagically use Valgrind for tests.
+ sed -i -e 's:valgrind --error-exitcode=1:false:' init.cfg || die
+
+ emake VERBOSE=yes check
+}
+
src_install() {
default