summaryrefslogtreecommitdiff
path: root/sys-apps/sed/sed-4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
commit1dde4e5c4b92d849bf1abf0a48135b2a0644f7e1 (patch)
treec99a472cce74148d499f42ada873454b0e32a42d /sys-apps/sed/sed-4.4.ebuild
parentda6a52f691ef980bab92d003d5df8f463c623af8 (diff)
gentoo resync : 13.03.2018
Diffstat (limited to 'sys-apps/sed/sed-4.4.ebuild')
-rw-r--r--sys-apps/sed/sed-4.4.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sys-apps/sed/sed-4.4.ebuild b/sys-apps/sed/sed-4.4.ebuild
index aa52e2921cdc..3bdb8e28ac20 100644
--- a/sys-apps/sed/sed-4.4.ebuild
+++ b/sys-apps/sed/sed-4.4.ebuild
@@ -25,13 +25,11 @@ DEPEND="${RDEPEND}
src_bootstrap_sed() {
# make sure system-sed works #40786
- export NO_SYS_SED=""
if ! type -p sed > /dev/null ; then
- NO_SYS_SED="!!!"
- ./bootstrap.sh || die "couldnt bootstrap"
- cp sed/sed "${T}"/ || die "couldnt copy"
- export PATH="${PATH}:${T}"
- make clean || die "couldnt clean"
+ mkdir -p "${T}/bootstrap"
+ printf '#!/bin/sh\nexec busybox sed "$@"\n' > "${T}/bootstrap/sed" || die
+ chmod a+rx "${T}/bootstrap/sed"
+ PATH="${T}/bootstrap:${PATH}"
fi
}