summaryrefslogtreecommitdiff
path: root/sys-apps/sed/sed-4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-02 17:36:40 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-02 17:36:40 +0100
commit171a011ad3a131671aeb5a98b9e3adf219ad2865 (patch)
tree0c877a3d1a37f10e37ad7168cfc52054aa0948a7 /sys-apps/sed/sed-4.4.ebuild
parent75fc75ae1f0481ffdb78450e801a9b443ba641bd (diff)
gentoo resync : 02.04.2018
Diffstat (limited to 'sys-apps/sed/sed-4.4.ebuild')
-rw-r--r--sys-apps/sed/sed-4.4.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/sys-apps/sed/sed-4.4.ebuild b/sys-apps/sed/sed-4.4.ebuild
deleted file mode 100644
index 3bdb8e28ac20..000000000000
--- a/sys-apps/sed/sed-4.4.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Super-useful stream editor"
-HOMEPAGE="http://sed.sourceforge.net/"
-SRC_URI="mirror://gnu/sed/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="acl nls selinux static"
-
-RDEPEND="acl? ( virtual/acl )
- nls? ( virtual/libintl )
- selinux? ( sys-libs/libselinux )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-#PATCHES=(
-#)
-
-src_bootstrap_sed() {
- # make sure system-sed works #40786
- if ! type -p sed > /dev/null ; then
- mkdir -p "${T}/bootstrap"
- printf '#!/bin/sh\nexec busybox sed "$@"\n' > "${T}/bootstrap/sed" || die
- chmod a+rx "${T}/bootstrap/sed"
- PATH="${T}/bootstrap:${PATH}"
- fi
-}
-
-src_prepare() {
- #epatch "${PATCHES[@]}"
-
- # don't use sed before bootstrap if we have to recover a broken host sed
- src_bootstrap_sed
-}
-
-src_configure() {
- local myconf=()
- if use userland_GNU; then
- myconf+=( --exec-prefix="${EPREFIX}" )
- else
- myconf+=( --program-prefix=g )
- fi
-
- export ac_cv_search_setfilecon=$(usex selinux -lselinux)
- export ac_cv_header_selinux_{context,selinux}_h=$(usex selinux)
- use static && append-ldflags -static
- myconf+=(
- $(use_enable acl)
- $(use_enable nls)
- )
- econf "${myconf[@]}"
-}