summaryrefslogtreecommitdiff
path: root/sys-apps/secilc/secilc-3.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-30 03:54:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-30 03:54:54 +0100
commitde9b2d9850ea1cb41c216274646d749ccec8c311 (patch)
treedf9e5db7e51d2a53e8ead0c8c3f01af0bf56df6d /sys-apps/secilc/secilc-3.5.ebuild
parent911d13b08c9edf41dd5fd5f5e15c952ca1fc3b6c (diff)
gentoo auto-resync : 30:03:2023 - 03:54:54
Diffstat (limited to 'sys-apps/secilc/secilc-3.5.ebuild')
-rw-r--r--sys-apps/secilc/secilc-3.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/secilc/secilc-3.5.ebuild b/sys-apps/secilc/secilc-3.5.ebuild
new file mode 100644
index 000000000000..76eeb7422445
--- /dev/null
+++ b/sys-apps/secilc/secilc-3.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+inherit toolchain-funcs
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SELinux Common Intermediate Language (CIL) Compiler"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}"
+RDEPEND="${DEPEND}"
+BDEPEND="app-text/xmlto"
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_compile() {
+ tc-export CC
+ default
+}