summaryrefslogtreecommitdiff
path: root/sys-apps/ripgrep/ripgrep-0.10.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /sys-apps/ripgrep/ripgrep-0.10.0-r1.ebuild
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'sys-apps/ripgrep/ripgrep-0.10.0-r1.ebuild')
-rw-r--r--sys-apps/ripgrep/ripgrep-0.10.0-r1.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/sys-apps/ripgrep/ripgrep-0.10.0-r1.ebuild b/sys-apps/ripgrep/ripgrep-0.10.0-r1.ebuild
index f5c384a3c895..f7eda9ddd13b 100644
--- a/sys-apps/ripgrep/ripgrep-0.10.0-r1.ebuild
+++ b/sys-apps/ripgrep/ripgrep-0.10.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -116,25 +116,16 @@ src_test() {
}
src_compile() {
- export CARGO_HOME="${ECARGO_HOME}"
- cargo build -j $(makeopts_jobs) \
- $(usex debug "" --release) \
- $(usex pcre "--features pcre2" "") \
- || die "cargo build failed"
+ cargo_src_compile $(usex pcre "--features pcre2" "")
}
src_install() {
- cargo install -j $(makeopts_jobs) --root="${D}/usr" \
- $(usex debug --debug "") \
- $(usex pcre "--features pcre2" "") \
- || die "cargo install failed"
-
- rm -f "${D}/usr/.crates.toml" || die
+ cargo_src_install $(usex pcre "--features pcre2" "")
# hack to find/install generated files
# stamp file can be present in multiple dirs if we build additional features
# so grab fist match only
- local BUILD_DIR=$(dirname $(find target/release -name ripgrep-stamp -print -quit))
+ local BUILD_DIR="$(dirname $(find target/release -name ripgrep-stamp -print -quit))"
if use man ; then
doman "${BUILD_DIR}"/rg.1