summaryrefslogtreecommitdiff
path: root/sys-apps/qdirstat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sys-apps/qdirstat
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sys-apps/qdirstat')
-rw-r--r--sys-apps/qdirstat/Manifest3
-rw-r--r--sys-apps/qdirstat/files/qdirstat-1.8-musl.patch102
-rw-r--r--sys-apps/qdirstat/qdirstat-1.8.ebuild4
3 files changed, 107 insertions, 2 deletions
diff --git a/sys-apps/qdirstat/Manifest b/sys-apps/qdirstat/Manifest
index 157a5089b562..9926cdd58ddf 100644
--- a/sys-apps/qdirstat/Manifest
+++ b/sys-apps/qdirstat/Manifest
@@ -1,3 +1,4 @@
+AUX qdirstat-1.8-musl.patch 3034 BLAKE2B d2e2d5c6a5c56f3d06153dd5076b32f4c1ef322c98fbc6cc24894bf2dd7e1a0c7a87051f1c4aee506e3076f0c446a247f1b677d41a8e10c625aa36d6e3d643e2 SHA512 668ca90e441284dcca1f1fa3f1841806e0a2b23cfeb04ccd1b1d3a43c5feacb582d70b021d40d3506d998b38886df71ea39ce7d780836adce7db9007fe0f71e1
DIST qdirstat-1.8.tar.gz 8720791 BLAKE2B fd1da935e82c7cdb2880e3a1e2902627c7f3e2972d08ae83a7ca49c4f641c07184c791471fb7a62211660f6e9bfb6fd0dc309c26c0fcffa1cad98de029e2b384 SHA512 fb7b757cf08c6b6ec0c14be9b08b8b6784a36e100c3ac89dbaef176ef908e43c47c2788fc4002a5e5f7308c990518cb3a104166e12cec605ff1a586bd7a4af10
-EBUILD qdirstat-1.8.ebuild 991 BLAKE2B 4799e6e46bfd638075328690e6a82bf3cc5b01c3d97951352cbf0eeb1261b7594796cc445f3d9b6e1306c15cd6fd5f84ebc0fbfe7b20097a43382db5111939c9 SHA512 7b18d715f765dc7fbf6a1ebf95ff91ed10f90f5ad38e6f0c3e6cb3d5faffa0dc604e608e98d2cef185b8e8b24738780189fdbee56bce4815cbd3b5841e302f02
+EBUILD qdirstat-1.8.ebuild 1039 BLAKE2B 0e0dea4df65d195532203ff52ce96a5e670d4aa64a00e1a45bed6c1e285cb2c90a08677f77acd8a5d382a2f315fe805a1aaa818d4b2200c6a326c24279a7ba2f SHA512 7d185f56aa24aff8b0cca6a12e9a66610c8039c6039191ef30a8d31fbabb996e586d74d38ee289d793d4641f17ffb364939335a6094188dd21cdd3b7e5600e25
MISC metadata.xml 883 BLAKE2B b5a3c4f300c991de6174a8e46c9dfe672e9293713d5174b182d9cce2354840c9afa63aea8d5335e1bae365c12440ac93290a3abe46f7cff5264179835ba0a719 SHA512 5b23f2d2bd68dc0562df3cd78a066980cccedb5f7f3dca98b200b7b0ccf739a4a01a2fe84accd6fa96b2ceed5b35087db915b3cdd0d9af2cd080d4a590f4ce08
diff --git a/sys-apps/qdirstat/files/qdirstat-1.8-musl.patch b/sys-apps/qdirstat/files/qdirstat-1.8-musl.patch
new file mode 100644
index 000000000000..e730352a8040
--- /dev/null
+++ b/sys-apps/qdirstat/files/qdirstat-1.8-musl.patch
@@ -0,0 +1,102 @@
+From ca2c6c4a0a90ed467af9c4c73b918dd4bf720f2a Mon Sep 17 00:00:00 2001
+From: Stefan Hundhammer <Stefan.Hundhammer@gmx.de>
+Date: Wed, 9 Feb 2022 11:05:31 +0100
+Subject: [PATCH] Fixed GitHub issue #187: ALLPERMS not defined in libc-musl
+
+---
+ src/BrokenLibc.h | 45 +++++++++++++++++++++++++++++++++++++++++++++
+ src/FileInfo.cpp | 1 +
+ src/FormatUtil.cpp | 1 +
+ src/src.pro | 3 ++-
+ 4 files changed, 49 insertions(+), 1 deletion(-)
+ create mode 100644 src/BrokenLibc.h
+
+diff --git a/src/BrokenLibc.h b/src/BrokenLibc.h
+new file mode 100644
+index 00000000..8bdf2a84
+--- /dev/null
++++ b/src/BrokenLibc.h
+@@ -0,0 +1,45 @@
++/*
++ * File name: BrokenLibc.h
++ * Summary: Substitutes for common system-level defines
++ * License: GPL V2 - See file LICENSE for details.
++ *
++ * Author: Stefan Hundhammer <Stefan.Hundhammer@gmx.de>
++ */
++
++#ifndef BrokenLibc_h
++#define BrokenLibc_h
++
++// This contains common #defines that are present on modern systems, but
++// sometimes not on systems that insist to exchange known working subsystems
++// such as glibc with their own version, commonly because of the "not invented
++// here" syndrome.
++
++
++// Make sure the original defines are available regardless of include order
++
++#include <sys/stat.h> // ALLPERMS
++
++
++#ifndef ALLPERMS
++# define ALLPERMS 07777
++
++// Uncomment for debugging:
++// # warning "Using ALLPERMS replacement"
++
++// Not available in musl-libc used on Gentoo:
++//
++// https://github.com/shundhammer/qdirstat/issues/187
++//
++// Original from Linux / glibc /usr/include/x86_64-linux-gnu/sys/stat.h :
++//
++// #define ALLPERMS (S_ISUID|S_ISGID|S_ISVTX|S_IRWXU|S_IRWXG|S_IRWXO)/* 07777 */
++//
++// But that might induce more complaints because any of S_IRWXU, S_IRWXG
++// etc. may also not be defined on such a system. So let's keep it simple.
++// If they also use a different bit pattern for those permissions, that's their
++// problem.
++#endif
++
++
++
++#endif // BrokenLibc_h
+diff --git a/src/FileInfo.cpp b/src/FileInfo.cpp
+index 6be13a8d..d8195819 100644
+--- a/src/FileInfo.cpp
++++ b/src/FileInfo.cpp
+@@ -26,6 +26,7 @@
+ #include "SysUtil.h"
+ #include "Logger.h"
+ #include "Exception.h"
++#include "BrokenLibc.h" // ALLPERMS
+
+ // Some filesystems (NTFS seems to be among them) may handle block fragments
+ // well. Don't report files as "sparse" files if the block size is only a few
+diff --git a/src/FormatUtil.cpp b/src/FormatUtil.cpp
+index 6c755d79..43ca9ec4 100644
+--- a/src/FormatUtil.cpp
++++ b/src/FormatUtil.cpp
+@@ -11,6 +11,7 @@
+ #include <QTextStream>
+
+ #include "FormatUtil.h"
++#include "BrokenLibc.h" // ALLPERMS
+
+ using namespace QDirStat;
+
+diff --git a/src/src.pro b/src/src.pro
+index c9616462..50b51ca4 100644
+--- a/src/src.pro
++++ b/src/src.pro
+@@ -157,7 +157,8 @@ HEADERS = \
+ ActionManager.h \
+ AdaptiveTimer.h \
+ Attic.h \
+- BreadcrumbNavigator.h \
++ BreadcrumbNavigator.h \
++ BrokenLibc.h \
+ BucketsTableModel.h \
+ BusyPopup.h \
+ Cleanup.h \
diff --git a/sys-apps/qdirstat/qdirstat-1.8.ebuild b/sys-apps/qdirstat/qdirstat-1.8.ebuild
index 64ab49423bd4..62fb4a2c928d 100644
--- a/sys-apps/qdirstat/qdirstat-1.8.ebuild
+++ b/sys-apps/qdirstat/qdirstat-1.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -26,6 +26,8 @@ RDEPEND="
dev-perl/URI
"
+PATCHES=( "${FILESDIR}/${PN}-1.8-musl.patch" )
+
src_prepare() {
default