summaryrefslogtreecommitdiff
path: root/sys-apps/preload/preload-0.6.4-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /sys-apps/preload/preload-0.6.4-r3.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'sys-apps/preload/preload-0.6.4-r3.ebuild')
-rw-r--r--sys-apps/preload/preload-0.6.4-r3.ebuild38
1 files changed, 22 insertions, 16 deletions
diff --git a/sys-apps/preload/preload-0.6.4-r3.ebuild b/sys-apps/preload/preload-0.6.4-r3.ebuild
index 486415f63b80..97f7518dbe0d 100644
--- a/sys-apps/preload/preload-0.6.4-r3.ebuild
+++ b/sys-apps/preload/preload-0.6.4-r3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit eutils autotools
+EAPI=7
+
+inherit autotools
DESCRIPTION="Adaptive readahead daemon"
HOMEPAGE="https://sourceforge.net/projects/preload/"
@@ -13,20 +14,26 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="vanilla"
-RDEPEND=">=dev-libs/glib-2.6:2"
-DEPEND="${RDEPEND}
+BDEPEND="
+ sys-apps/help2man
virtual/pkgconfig
- sys-apps/help2man"
+"
+RDEPEND=">=dev-libs/glib-2.6:2"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/00-patch-configure.diff
+ "${FILESDIR}"/02-patch-preload_conf.diff
+ "${FILESDIR}"/02-patch-preload_sysconfig.diff
+ "${FILESDIR}"/${PN}-0.6.4-use-help2man-as-usual.patch
+ "${FILESDIR}"/${PN}-0.6.4-use-make-dependencies.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/00-patch-configure.diff
- epatch "${FILESDIR}"/02-patch-preload_conf.diff
- epatch "${FILESDIR}"/02-patch-preload_sysconfig.diff
- epatch "${FILESDIR}"/${PN}-0.6.4-use-help2man-as-usual.patch
- epatch "${FILESDIR}"/${PN}-0.6.4-use-make-dependencies.patch
- use vanilla || epatch "${FILESDIR}"/000{1,2,3}-*.patch
- cat "${FILESDIR}"/preload-0.6.4.init.in-r2 > preload.init.in || die
+ use vanilla || eapply "${FILESDIR}"/000{1,2,3}-*.patch
+ default
+ cat "${FILESDIR}"/preload-0.6.4.init.in-r2 > preload.init.in || die
eautoreconf
}
@@ -46,16 +53,15 @@ src_install() {
}
pkg_postinst() {
- if [ "$(rc-config list default | grep preload)" = "" ] ; then
+ if [[ "$(rc-config list default | grep preload)" = "" ]] ; then
elog "You probably want to add preload to the default runlevel like so:"
elog "# rc-update add preload default"
fi
- if has_version sys-fs/e4rat; then
+ if has_version sys-fs/e4rat ; then
elog "It appears you have sys-fs/e4rat installed. This may"
elog "has negative effects on it. You may want to disable preload"
elog "when using sys-fs/e4rat."
elog "http://e4rat.sourceforge.net/wiki/index.php/Main_Page#Debian.2FUbuntu"
-
fi
}