summaryrefslogtreecommitdiff
path: root/sys-apps/prctl/prctl-1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/prctl/prctl-1.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/prctl/prctl-1.6.ebuild')
-rw-r--r--sys-apps/prctl/prctl-1.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-apps/prctl/prctl-1.6.ebuild b/sys-apps/prctl/prctl-1.6.ebuild
new file mode 100644
index 000000000000..24ac9dace8ef
--- /dev/null
+++ b/sys-apps/prctl/prctl-1.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to query and modify process behavior"
+HOMEPAGE="https://sourceforge.net/projects/prctl/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="sys-apps/groff"
+
+PATCHES=("${FILESDIR}"/${P}-no-implicits.patch)
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin prctl
+ doman prctl.1
+ dodoc ChangeLog
+}