summaryrefslogtreecommitdiff
path: root/sys-apps/ppc64-diag/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /sys-apps/ppc64-diag/files
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'sys-apps/ppc64-diag/files')
-rw-r--r--sys-apps/ppc64-diag/files/fix-systemd-unit-path.patch38
-rw-r--r--sys-apps/ppc64-diag/files/opal_errd.initd15
-rw-r--r--sys-apps/ppc64-diag/files/rtas_errd.initd15
3 files changed, 68 insertions, 0 deletions
diff --git a/sys-apps/ppc64-diag/files/fix-systemd-unit-path.patch b/sys-apps/ppc64-diag/files/fix-systemd-unit-path.patch
new file mode 100644
index 000000000000..e11feca7a49c
--- /dev/null
+++ b/sys-apps/ppc64-diag/files/fix-systemd-unit-path.patch
@@ -0,0 +1,38 @@
+From 60a26c23d2d385e62a006d68074ca25479e10639 Mon Sep 17 00:00:00 2001
+From: Georgy Yakovlev <gyakovlev@gentoo.org>
+Date: Wed, 15 Jan 2020 20:27:31 -0800
+Subject: [PATCH] fix systemd unit path
+
+---
+ scripts/Makefile.am | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/scripts/Makefile.am b/scripts/Makefile.am
+index 29dcb78..36efcfb 100644
+--- a/scripts/Makefile.am
++++ b/scripts/Makefile.am
+@@ -16,8 +16,8 @@ install-exec-hook-scripts:
+ install -D --mode=644 $(CONFIG_FILE) $(DESTDIR)/etc/ppc64-diag
+ install -d --mode=755 $(DESTDIR)/usr/libexec/ppc64-diag/
+ install -D --mode=755 $(INIT_FILES) $(DESTDIR)/usr/libexec/ppc64-diag/
+- install -d --mode=755 $(DESTDIR)/usr/lib/systemd/system/
+- install -D --mode=644 $(SERVICE_SCRIPT) $(DESTDIR)/usr/lib/systemd/system/
++ install -d --mode=755 $(DESTDIR)/lib/systemd/system/
++ install -D --mode=644 $(SERVICE_SCRIPT) $(DESTDIR)/lib/systemd/system/
+
+ uninstall-hook-scripts:
+ rm -f $(DESTDIR)/etc/ppc64-diag/ppc64_diag_setup
+@@ -28,8 +28,8 @@ uninstall-hook-scripts:
+ rm -f $(DESTDIR)/etc/ppc64-diag/ppc64-diag.config
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/rtas_errd
+ rm -f $(DESTDIR)/usr/libexec/ppc64-diag/opal_errd
+- rm -f $(DESTDIR)/usr/lib/systemd/system/rtas_errd.service
+- rm -f $(DESTDIR)/usr/lib/systemd/system/opal_errd.service
++ rm -f $(DESTDIR)/lib/systemd/system/rtas_errd.service
++ rm -f $(DESTDIR)/lib/systemd/system/opal_errd.service
+
+ INSTALL_EXEC_HOOKS += install-exec-hook-scripts
+ UNINSTALL_HOOKS += uninstall-hook-scripts
+--
+2.25.0
+
diff --git a/sys-apps/ppc64-diag/files/opal_errd.initd b/sys-apps/ppc64-diag/files/opal_errd.initd
new file mode 100644
index 000000000000..ee420f1f9aca
--- /dev/null
+++ b/sys-apps/ppc64-diag/files/opal_errd.initd
@@ -0,0 +1,15 @@
+#!/sbin/openrc-run
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name="opal_errd daemon"
+description="Daemon to read/parse OPAL platform error(s)/event(s)"
+command=/usr/sbin/opal_errd
+command_args="-w ${opal_errd_args}"
+command_background=true
+pidfile="/run/${RC_SVCNAME}.pid"
+
+depend() {
+ need localmount
+ use logger
+}
diff --git a/sys-apps/ppc64-diag/files/rtas_errd.initd b/sys-apps/ppc64-diag/files/rtas_errd.initd
new file mode 100644
index 000000000000..213f91cf0022
--- /dev/null
+++ b/sys-apps/ppc64-diag/files/rtas_errd.initd
@@ -0,0 +1,15 @@
+#!/sbin/openrc-run
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name="rtas_errd daemon"
+description="Daemon to read/parse RTAS platform error(s)/event(s)"
+command=/usr/sbin/rtas_errd
+command_args="${rtas_errd_args}"
+command_background=true
+pidfile="/run/${RC_SVCNAME}.pid"
+
+depend() {
+ need localmount
+ use logger
+}