summaryrefslogtreecommitdiff
path: root/sys-apps/pkgcore/pkgcore-0.12.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-21 08:02:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-21 08:02:07 +0100
commitf1269e587f3d88b85f72a6fbaf727da5d6c9af90 (patch)
treeec99a8c7cdea447c38d3015894c269b8bc1e95af /sys-apps/pkgcore/pkgcore-0.12.16.ebuild
parent3518f21ee7106f4268edf4404299dda157795e3c (diff)
gentoo auto-resync : 21:10:2022 - 08:02:07
Diffstat (limited to 'sys-apps/pkgcore/pkgcore-0.12.16.ebuild')
-rw-r--r--sys-apps/pkgcore/pkgcore-0.12.16.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/sys-apps/pkgcore/pkgcore-0.12.16.ebuild b/sys-apps/pkgcore/pkgcore-0.12.16.ebuild
deleted file mode 100644
index 9eb8420dfb20..000000000000
--- a/sys-apps/pkgcore/pkgcore-0.12.16.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/pkgcore/pkgcore"
- inherit git-r3
-else
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-fi
-
-DESCRIPTION="a framework for package management"
-HOMEPAGE="https://github.com/pkgcore/pkgcore"
-
-LICENSE="BSD MIT"
-SLOT="0"
-
-RDEPEND="
- >=app-shells/bash-5.0
- dev-python/lxml[${PYTHON_USEDEP}]
-"
-if [[ ${PV} == *9999 ]]; then
- RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
-else
- RDEPEND+=" >=dev-python/snakeoil-0.10.0[${PYTHON_USEDEP}]"
-fi
-BDEPEND="
- test? (
- >=dev-python/pytest-6[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-
-distutils_enable_tests setup.py
-
-src_test() {
- # With PYTHONDONTWRITEBYTECODE=, python will try rebuild all sorts of modules.
- # https://bugs.gentoo.org/840266
- local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
- addpredict /
-
- local -x PYTHONDONTWRITEBYTECODE=
- distutils-r1_src_test
-}
-
-python_install_all() {
- local DOCS=( NEWS.rst )
- [[ ${PV} == *9999 ]] || doman man/*
- distutils-r1_python_install_all
-}