summaryrefslogtreecommitdiff
path: root/sys-apps/pkgcore/pkgcore-0.12.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-16 23:15:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-16 23:15:49 +0100
commit3b827127cdc24d49f3dbaa82def6c80501d2cd87 (patch)
tree4e3f67cb234339d4cb7c29ee99550a3362d5a1ca /sys-apps/pkgcore/pkgcore-0.12.14.ebuild
parent6e356edde093fb3589ab7a5859685e85c2873ab0 (diff)
gentoo auto-resync : 16:09:2022 - 23:15:49
Diffstat (limited to 'sys-apps/pkgcore/pkgcore-0.12.14.ebuild')
-rw-r--r--sys-apps/pkgcore/pkgcore-0.12.14.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-apps/pkgcore/pkgcore-0.12.14.ebuild b/sys-apps/pkgcore/pkgcore-0.12.14.ebuild
new file mode 100644
index 000000000000..533d30e95bf9
--- /dev/null
+++ b/sys-apps/pkgcore/pkgcore-0.12.14.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pkgcore.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a framework for package management"
+HOMEPAGE="https://github.com/pkgcore/pkgcore"
+
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="
+ >=app-shells/bash-5.0
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND+=" >=dev-python/snakeoil-0.9.12[${PYTHON_USEDEP}]"
+fi
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests setup.py
+
+src_test() {
+ # With PYTHONDONTWRITEBYTECODE=, python will try rebuild all sorts of modules.
+ # https://bugs.gentoo.org/840266
+ local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
+ addpredict /
+
+ local -x PYTHONDONTWRITEBYTECODE=
+ distutils-r1_src_test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst )
+ [[ ${PV} == *9999 ]] || doman man/*
+ distutils-r1_python_install_all
+}