summaryrefslogtreecommitdiff
path: root/sys-apps/pick/pick-4.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /sys-apps/pick/pick-4.0.0.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'sys-apps/pick/pick-4.0.0.ebuild')
-rw-r--r--sys-apps/pick/pick-4.0.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/pick/pick-4.0.0.ebuild b/sys-apps/pick/pick-4.0.0.ebuild
new file mode 100644
index 000000000000..9bf033c64ad7
--- /dev/null
+++ b/sys-apps/pick/pick-4.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="a fuzzy search tool for the command-line"
+HOMEPAGE="https://github.com/mptre/pick"
+SRC_URI="https://github.com/mptre/pick/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.0.0-tinfo.patch"
+)
+
+src_configure() {
+ # not autoconf
+ ./configure || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" BINDIR=/usr/bin MANDIR=/usr/share/man install
+ dodoc CHANGELOG.md
+}