summaryrefslogtreecommitdiff
path: root/sys-apps/pcsc-lite
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-30 04:55:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-30 04:55:37 +0000
commite984f0bb49fed14c51c7c15ed8d7b8bd2cca4b1d (patch)
tree99c30d1c04aa29f440b825a7bf68be3c8f9e75d1 /sys-apps/pcsc-lite
parente7b6f003e8384cdfc8c0e7603329e969d8806c24 (diff)
gentoo auto-resync : 30:11:2023 - 04:55:37
Diffstat (limited to 'sys-apps/pcsc-lite')
-rw-r--r--sys-apps/pcsc-lite/Manifest2
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-2.0.1.ebuild109
2 files changed, 111 insertions, 0 deletions
diff --git a/sys-apps/pcsc-lite/Manifest b/sys-apps/pcsc-lite/Manifest
index ce1307dbfccd..e807ea587fcc 100644
--- a/sys-apps/pcsc-lite/Manifest
+++ b/sys-apps/pcsc-lite/Manifest
@@ -5,5 +5,7 @@ AUX pcscd-init.7 408 BLAKE2B 54e4995a169b7f816b0de9b409ae94a8328e792b50872d58398
AUX pcscd-udev 330 BLAKE2B 50e99953aec238fe98c6aee5219d3978b44d37c90ce74c9cb8e19b37c8677001e9b1b3701df8246bf051c6cf8b5c971f86bf1f580bfcbff270b8937328ca887d SHA512 06b672135fda9f83af4f030ff8078f8e1194ced529334c17c1a93f81ee9a5d4448bcea5ffec398f01d957a6607fbde7f69fbc23d727bb3ffad48a305cefe5c26
AUX pcscd.conf 32 BLAKE2B 2407e00c654d7e259ebf69ab420800f5605cb3ead23eb4aa07317928c38b6328eae2e566fab84c8844fb80e8a165cd32982fee753498b20c7a750f52fbb1f995 SHA512 ae27cdab8a60201639b9d9aca2d7f760146a5c5238878a0ebb562740385bf58f04bbc37a19cd1a2c8c69ee463f10beecc6531dde733cb6a6d4b06816f54b1569
DIST pcsc-lite-2.0.0.tar.bz2 799011 BLAKE2B d93fffebbe3daf389fcd8195c9fb3d76db64dbb98ac9c7ecd08338331389298e710ca71187cb73165868b0b5e66cb9735b60e22d508db1c1a81e04555103948a SHA512 4b34628d3269ae1859f19d2ab7eb74a76a55f3d76fbc9e4e420a081a065b1d0d7b98680552c7208f3265c684bed844afc6be1c2e5f103ad916ce7f38b52ee68c
+DIST pcsc-lite-2.0.1.tar.bz2 815103 BLAKE2B a9eea4a4da1a78fc22797b17c128889b2f7caf8c4aa02dd77f4ac79e4ec458fb0162578b5422552545cd39303750d5396f3687f8cfee7603fad8d60cb54ee1e8 SHA512 af007f00f43e8d897710580f6f27814c9e7d3ca489ff01edf2e3b979e46267915aa04d9c15f225a420fa681de936e42a1d4779d962717cf9a9f4a3d1ca31502b
EBUILD pcsc-lite-2.0.0.ebuild 3341 BLAKE2B bbf57e22016a27fd22ea340263fe6d83192d9021929a4630c7e4f364dac2a8ed043f243cc6d895858114cc518a8e5c06fb7d75c44063cbf38a6375524b1d524e SHA512 0cfa761798bfec55812f6aab495d13d1326d3b6732f2d5da1796a35a68bfff6bb48e911a8f0dc28c2724ae643196b9a43f515c026ee712f72a2c1677803653c4
+EBUILD pcsc-lite-2.0.1.ebuild 3348 BLAKE2B 9dc2805c2cea1bb4aef46bd2a653e09c90d846d6346000ff4bcda0ddc1f59a45d340ec4e52c2149dfe7bf76ca8e1b7d72a47a3de732c9642440684c0b7cdcc7d SHA512 53a99e5bfa73392ef19553ca6310b6daa1739a2c9610307215b922681a7b96238439d11612449df6065cc4816db8f44e6238bb2dd7731ba35e5d5b9fdadb31df
MISC metadata.xml 1147 BLAKE2B c89b7f5443b81af35a0debe239b95ffa3dea06c4e86c1cb3bfe50dfc81e49d32939ae2eaaabcc5b4c5947c69c8ae90ce278efafc324ff6ab10a9ed514fa0a8b3 SHA512 96aea50c57df7bf05d5e05d7dd19f985193638592526a1357680f3e3489c0680b38f2f732714a0726097e40503bf1573b5458d4917fbcf1cbfeb56953d05293f
diff --git a/sys-apps/pcsc-lite/pcsc-lite-2.0.1.ebuild b/sys-apps/pcsc-lite/pcsc-lite-2.0.1.ebuild
new file mode 100644
index 000000000000..3a0cf3c74caa
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-2.0.1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit python-single-r1 systemd tmpfiles udev multilib-minimal
+
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="https://pcsclite.apdu.fr https://github.com/LudovicRousseau/PCSC"
+SRC_URI="https://pcsclite.apdu.fr/files/${P}.tar.bz2"
+
+# GPL-2 is there for the init script; everything else comes from
+# upstream.
+LICENSE="BSD ISC MIT GPL-3+ GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+# This is called libusb so that it doesn't fool people in thinking that
+# it is _required_ for USB support. Otherwise they'll disable udev and
+# that's going to be worse.
+IUSE="doc embedded libusb policykit selinux systemd +udev"
+REQUIRED_USE="^^ ( udev libusb ) ${PYTHON_REQUIRED_USE}"
+
+# No dependencies need the MULTILIB_DEPS because the libraries are actually
+# standalone, the deps are only needed for the daemon itself.
+DEPEND="
+ libusb? ( virtual/libusb:1 )
+ udev? ( virtual/libudev:= )
+ policykit? ( >=sys-auth/polkit-0.111 )
+ acct-group/openct
+ acct-group/pcscd
+ acct-user/pcscd
+ ${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-pcscd )"
+BDEPEND="
+ sys-devel/flex
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.11-polkit-pcscd.patch
+ "${FILESDIR}"/${PN}-1.9.8-systemd-user.patch
+)
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-maintainer-mode \
+ --disable-strict \
+ --enable-usbdropdir="${EPREFIX}"/usr/$(get_libdir)/readers/usb \
+ --enable-ipcdir=/run/pcscd \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ $(multilib_native_use_enable doc documentation) \
+ $(multilib_native_use_enable embedded) \
+ $(multilib_native_use_enable systemd libsystemd) \
+ $(multilib_native_use_enable udev libudev) \
+ $(multilib_native_use_enable libusb) \
+ $(multilib_native_use_enable policykit polkit)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ dodoc HELP SECURITY
+
+ newinitd "${FILESDIR}"/pcscd-init.7 pcscd
+ dotmpfiles "${FILESDIR}"/pcscd.conf
+
+ if use udev; then
+ exeinto "$(get_udevdir)"
+ newexe "${FILESDIR}"/pcscd-udev pcscd.sh
+
+ insinto "$(get_udevdir)"/rules.d
+ newins "${FILESDIR}"/99-pcscd-hotplug-r1.rules 99-pcscd-hotplug.rules
+ fi
+
+ python_fix_shebang "${ED}"/usr/bin/pcsc-spy
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "Starting from version 1.6.5, pcsc-lite will start as user nobody in"
+ elog "the pcscd group, to avoid running as root."
+ elog
+ elog "This also means you need the newest drivers available so that the"
+ elog "devices get the proper owner."
+ elog
+ elog "Furthermore, a conf.d file is no longer installed by default, as"
+ elog "the default configuration does not require one. If you need to"
+ elog "pass further options to pcscd, create a file and set the"
+ elog "EXTRA_OPTS variable."
+ elog
+
+ if use udev; then
+ elog "Hotplug support is provided by udev rules."
+ elog "When using OpenRC you additionally need to tell it to hotplug"
+ elog "pcscd by setting this variable in /etc/rc.conf:"
+ elog
+ elog " rc_hotplug=\"pcscd\""
+ fi
+
+ tmpfiles_process pcscd.conf
+
+ use udev && udev_reload
+}
+
+pkg_postrm() {
+ use udev && udev_reload
+}