summaryrefslogtreecommitdiff
path: root/sys-apps/opentmpfiles/opentmpfiles-0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /sys-apps/opentmpfiles/opentmpfiles-0.2.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'sys-apps/opentmpfiles/opentmpfiles-0.2.ebuild')
-rw-r--r--sys-apps/opentmpfiles/opentmpfiles-0.2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys-apps/opentmpfiles/opentmpfiles-0.2.ebuild b/sys-apps/opentmpfiles/opentmpfiles-0.2.ebuild
index a7f5363a4cad..51ee0dc3233f 100644
--- a/sys-apps/opentmpfiles/opentmpfiles-0.2.ebuild
+++ b/sys-apps/opentmpfiles/opentmpfiles-0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,7 +10,7 @@ if [[ ${PV} = 9999* ]]; then
else
SRC_URI="https://github.com/openrc/${PN}/archive/${PV}.tar.gz ->
${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+ KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
DESCRIPTION="A standalone utility to process systemd-style tmpfiles.d files"
@@ -42,6 +42,7 @@ add_service() {
local runlevel=$2
elog "Auto-adding '${initd}' service to your ${runlevel} runlevel"
+ mkdir -p "${EROOT}"etc/runlevels/${runlevel}
ln -snf /etc/init.d/${initd} "${EROOT}"etc/runlevels/${runlevel}/${initd}
}