summaryrefslogtreecommitdiff
path: root/sys-apps/moreutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /sys-apps/moreutils
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'sys-apps/moreutils')
-rw-r--r--sys-apps/moreutils/Manifest3
-rw-r--r--sys-apps/moreutils/files/moreutils-0.63-respect-env.patch38
-rw-r--r--sys-apps/moreutils/moreutils-0.63.ebuild8
3 files changed, 46 insertions, 3 deletions
diff --git a/sys-apps/moreutils/Manifest b/sys-apps/moreutils/Manifest
index f873a71e58c9..c15456e84a7a 100644
--- a/sys-apps/moreutils/Manifest
+++ b/sys-apps/moreutils/Manifest
@@ -1,3 +1,4 @@
+AUX moreutils-0.63-respect-env.patch 1160 BLAKE2B 3d62cf5d86e22962093c1e7f315233d4da3643a809ff37af637bfc327001702f6e17e741e269c2c49b99ece922e46e435469c45f744bd67f07033018b43f9c83 SHA512 cfe8696cfd5502012dc500d44c632bd7cb143902c29b2a5bb545e309762d63a5bb41daed04a289d2b6b50be3c16256f897260471a38ac4adfd6a0b856ade1444
DIST moreutils_0.63.orig.tar.xz 80468 BLAKE2B 39efa522c5bf9b982b70c1180f622a7d5a489cabbeb741f2a1a0674dfe9907ef85bccccf9f9cc4ae8d3c81442b1513f0692c070b4c00f052135528dc0e47eb6f SHA512 71bd5ec4d265dff708db372189146acb067c4edaf62888755d245ccb3f4b5bb54f6c31bda68991f78c27ab231de8ea7126f947834f3604b60d7142d0357cb66b
-EBUILD moreutils-0.63.ebuild 1445 BLAKE2B 6cc4d0da336dd2aa3ea2bae611253c81d04de85ba8ca33da362130f2369c3360e403b772df2e53aba4958316929b8357b59173fa0f91d63b694efd5af12697a9 SHA512 5f187b5e75a072caea587b68f0349936af3f267114fe5c18f25b3a005ca71bc0c35494a974d7707ae4de58a44d96458cc7eb0f9e6d9e398635083d1ba55acf80
+EBUILD moreutils-0.63.ebuild 1495 BLAKE2B ec8305ce981fefadd7dd18773bbf6f6ef45f478bd88f6c1cef777e51c7d214e05fd80b68c95125c62833c17adeae10235adecd3ab0c586bd7825b418d79970fb SHA512 d4242878b139be134789bd5644bc97c46bf9a61a45186f1ba04e2c1ab8a3b627a0aea42797e695199d71e5aa8a151df75880c27a4852ad7559ba4406e2df0a67
MISC metadata.xml 427 BLAKE2B 311360aef2c49094822392ff35feb4bcbf03f16a909e6047a89c6280094d51b2347817dcd6938df998909101d53b8a14ee847f0eea5568bae6326ff01ebe2fee SHA512 d535b7f684ce284bf60ff162383773df08a753e9b2e80bcfe271cf39f0765719f8a00cffb46fed0c948e971875286bc9c3ca5972debfc3ed3653fcc33ac6a2a0
diff --git a/sys-apps/moreutils/files/moreutils-0.63-respect-env.patch b/sys-apps/moreutils/files/moreutils-0.63-respect-env.patch
new file mode 100644
index 000000000000..a4091cf599da
--- /dev/null
+++ b/sys-apps/moreutils/files/moreutils-0.63-respect-env.patch
@@ -0,0 +1,38 @@
+From 6c88aaa6b828d7bd7c1dccb3b842594d48c1764c Mon Sep 17 00:00:00 2001
+From: Nicolas Schier <nicolas@fjasle.eu>
+Date: Wed, 27 Nov 2019 21:16:12 +0100
+Subject: is_utf8: allow propagation of compiler and linker flags
+
+Allow propagating compiler and linker flags via overrides of CFLAGS and
+LDFLAGS variables. This allows enabling of hardening flags w/o
+modification of the original Makefile.
+
+Signed-off-by: Nicolas Schier <nicolas@fjasle.eu>
+---
+ is_utf8/Makefile | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/is_utf8/Makefile b/is_utf8/Makefile
+index 4ebf8be..13b1021 100644
+--- a/is_utf8/Makefile
++++ b/is_utf8/Makefile
+@@ -38,13 +38,13 @@ SONAME = $(LINKERNAME).$(VERSION)
+ REALNAME = $(SONAME).$(MINOR).$(RELEASE)
+
+ CC = gcc
+-CFLAGS = -O3 -Wextra -Wall -ansi -Wstrict-prototypes
++CFLAGS ?= -O3 -Wextra -Wall -ansi -Wstrict-prototypes
+
+ $(NAME): $(OBJ)
+- $(CC) $(CFLAGS) -o $(NAME) $(OBJ)
++ $(CC) $(CFLAGS) -o $(NAME) $(OBJ) $(LDFLAGS)
+
+ IS_UTF8_LIB:
+- $(CC) --shared -fPIC $(CFLAGS) $(LIB_SRC) -o $(LINKERNAME)
++ $(CC) --shared -fPIC $(CFLAGS) $(LDFLAGS) $(LIB_SRC) -o $(LINKERNAME)
+
+ all:
+ @make $(NAME)
+--
+cgit v1.2.3
+
diff --git a/sys-apps/moreutils/moreutils-0.63.ebuild b/sys-apps/moreutils/moreutils-0.63.ebuild
index cda09be7454f..4cb0b5d1cf8f 100644
--- a/sys-apps/moreutils/moreutils-0.63.ebuild
+++ b/sys-apps/moreutils/moreutils-0.63.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,7 +10,7 @@ SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm64 hppa ~ppc ~ppc64 x86 ~x86-linux"
+KEYWORDS="~alpha amd64 arm64 hppa ~ppc ~ppc64 x86 ~x86-linux"
IUSE="+doc +perl"
RDEPEND="
@@ -28,6 +28,10 @@ DEPEND="
app-text/docbook-xml-dtd:4.4
)"
+PATCHES=(
+ "${FILESDIR}"/${P}-respect-env.patch
+)
+
src_prepare() {
# don't build manpages
if ! use doc ; then