summaryrefslogtreecommitdiff
path: root/sys-apps/moreutils/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /sys-apps/moreutils/files
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'sys-apps/moreutils/files')
-rw-r--r--sys-apps/moreutils/files/moreutils-0.63-respect-env.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/moreutils/files/moreutils-0.63-respect-env.patch b/sys-apps/moreutils/files/moreutils-0.63-respect-env.patch
new file mode 100644
index 000000000000..a4091cf599da
--- /dev/null
+++ b/sys-apps/moreutils/files/moreutils-0.63-respect-env.patch
@@ -0,0 +1,38 @@
+From 6c88aaa6b828d7bd7c1dccb3b842594d48c1764c Mon Sep 17 00:00:00 2001
+From: Nicolas Schier <nicolas@fjasle.eu>
+Date: Wed, 27 Nov 2019 21:16:12 +0100
+Subject: is_utf8: allow propagation of compiler and linker flags
+
+Allow propagating compiler and linker flags via overrides of CFLAGS and
+LDFLAGS variables. This allows enabling of hardening flags w/o
+modification of the original Makefile.
+
+Signed-off-by: Nicolas Schier <nicolas@fjasle.eu>
+---
+ is_utf8/Makefile | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/is_utf8/Makefile b/is_utf8/Makefile
+index 4ebf8be..13b1021 100644
+--- a/is_utf8/Makefile
++++ b/is_utf8/Makefile
+@@ -38,13 +38,13 @@ SONAME = $(LINKERNAME).$(VERSION)
+ REALNAME = $(SONAME).$(MINOR).$(RELEASE)
+
+ CC = gcc
+-CFLAGS = -O3 -Wextra -Wall -ansi -Wstrict-prototypes
++CFLAGS ?= -O3 -Wextra -Wall -ansi -Wstrict-prototypes
+
+ $(NAME): $(OBJ)
+- $(CC) $(CFLAGS) -o $(NAME) $(OBJ)
++ $(CC) $(CFLAGS) -o $(NAME) $(OBJ) $(LDFLAGS)
+
+ IS_UTF8_LIB:
+- $(CC) --shared -fPIC $(CFLAGS) $(LIB_SRC) -o $(LINKERNAME)
++ $(CC) --shared -fPIC $(CFLAGS) $(LDFLAGS) $(LIB_SRC) -o $(LINKERNAME)
+
+ all:
+ @make $(NAME)
+--
+cgit v1.2.3
+