summaryrefslogtreecommitdiff
path: root/sys-apps/modutils/modutils-2.4.27-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/modutils/modutils-2.4.27-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/modutils/modutils-2.4.27-r1.ebuild')
-rw-r--r--sys-apps/modutils/modutils-2.4.27-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-apps/modutils/modutils-2.4.27-r1.ebuild b/sys-apps/modutils/modutils-2.4.27-r1.ebuild
new file mode 100644
index 000000000000..9123212c0c53
--- /dev/null
+++ b/sys-apps/modutils/modutils-2.4.27-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Standard kernel module utilities for linux-2.4 and older"
+HOMEPAGE="https://www.kernel.org/pub/linux/utils/kernel/modutils/"
+SRC_URI="mirror://kernel/linux/utils/kernel/${PN}/v2.4/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+RDEPEND="!sys-apps/module-init-tools
+ !sys-apps/kmod"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-alias.patch
+ epatch "${FILESDIR}"/${P}-gcc.patch
+ epatch "${FILESDIR}"/${P}-flex.patch
+ epatch "${FILESDIR}"/${P}-no-nested-function.patch
+}
+
+src_configure() {
+ econf \
+ --prefix=/ \
+ --disable-strip \
+ --enable-insmod-static \
+ --disable-zlib
+}
+
+src_install() {
+ einstall prefix="${D}"
+ rm -r "${ED}"/usr/share/man/man2 || die
+ dodoc CREDITS ChangeLog NEWS README TODO
+}