summaryrefslogtreecommitdiff
path: root/sys-apps/memtest86/files/memtest86-4.3.7-binutils-2.41-textrels.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-28 22:03:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-28 22:03:36 +0100
commit452411c00cad9fbb22e87ccc5840d8dd78ad9914 (patch)
tree995696599d3d79cdd8f26459c7db4d0f83147575 /sys-apps/memtest86/files/memtest86-4.3.7-binutils-2.41-textrels.patch
parenta5509b9be1fe380ed210b8279d996e1f1b03017a (diff)
gentoo auto-resync : 28:08:2023 - 22:03:35
Diffstat (limited to 'sys-apps/memtest86/files/memtest86-4.3.7-binutils-2.41-textrels.patch')
-rw-r--r--sys-apps/memtest86/files/memtest86-4.3.7-binutils-2.41-textrels.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/memtest86/files/memtest86-4.3.7-binutils-2.41-textrels.patch b/sys-apps/memtest86/files/memtest86-4.3.7-binutils-2.41-textrels.patch
new file mode 100644
index 000000000000..d95b96402be7
--- /dev/null
+++ b/sys-apps/memtest86/files/memtest86-4.3.7-binutils-2.41-textrels.patch
@@ -0,0 +1,31 @@
+https://bugs.gentoo.org/912343
+--- a/Makefile
++++ b/Makefile
+@@ -21,15 +21,15 @@ all: memtest.bin memtest
+ # symbols and then link it dynamically so I have full
+ # relocation information
+ memtest_shared: $(OBJS) memtest_shared.lds Makefile
+- $(LD) --warn-constructors --warn-common -static -T memtest_shared.lds -m elf_i386 \
++ $(LD) --warn-constructors --warn-common -static -z notext --no-warn-rwx-segments -T memtest_shared.lds -m elf_i386 \
+ -o $@ $(OBJS) && \
+- $(LD) -shared -Bsymbolic -T memtest_shared.lds -o $@ $(OBJS)
++ $(LD) -shared -Bsymbolic -z notext --no-warn-rwx-segments -T memtest_shared.lds -o $@ $(OBJS)
+
+ memtest_shared.bin: memtest_shared
+ objcopy -O binary $< memtest_shared.bin
+
+ memtest: memtest_shared.bin memtest.lds
+- $(LD) -s -T memtest.lds -b binary memtest_shared.bin -o $@
++ $(LD) -s -z notext --no-warn-rwx-segments -T memtest.lds -b binary memtest_shared.bin -o $@
+
+ head.s: head.S config.h defs.h test.h
+ $(CC) -E -traditional $< -o $@
+@@ -41,7 +41,7 @@ setup.s: setup.S config.h defs.h
+ $(CC) -E -traditional $< -o $@
+
+ memtest.bin: memtest_shared.bin bootsect.o setup.o memtest.bin.lds
+- $(LD) -T memtest.bin.lds bootsect.o setup.o -b binary \
++ $(LD) -z notext --no-warn-rwx-segments -T memtest.bin.lds bootsect.o setup.o -b binary \
+ memtest_shared.bin -o memtest.bin
+
+ reloc.o: reloc.c