summaryrefslogtreecommitdiff
path: root/sys-apps/mawk/mawk-1.3.4_p20150503.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/mawk/mawk-1.3.4_p20150503.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/mawk/mawk-1.3.4_p20150503.ebuild')
-rw-r--r--sys-apps/mawk/mawk-1.3.4_p20150503.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/mawk/mawk-1.3.4_p20150503.ebuild b/sys-apps/mawk/mawk-1.3.4_p20150503.ebuild
new file mode 100644
index 000000000000..8a27fa6e4d1e
--- /dev/null
+++ b/sys-apps/mawk/mawk-1.3.4_p20150503.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+MY_P=${P/_p/-}
+DESCRIPTION="an (often faster than gawk) awk-interpreter"
+HOMEPAGE="https://invisible-island.net/mawk/mawk.html"
+SRC_URI="ftp://invisible-island.net/mawk/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ia64 ppc sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+
+RDEPEND="app-eselect/eselect-awk"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( ACKNOWLEDGMENT CHANGES README )
+
+src_prepare() {
+ tc-export BUILD_CC
+}
+
+src_install() {
+ default
+
+ exeinto /usr/share/doc/${PF}/examples
+ doexe examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ eselect awk update ifunset
+}
+
+pkg_postrm() {
+ eselect awk update ifunset
+}