summaryrefslogtreecommitdiff
path: root/sys-apps/man-pages-posix/man-pages-posix-2017a-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-19 11:21:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-19 11:21:41 +0100
commit8668c0f6c5fd1d084b8b2bdac1cfa1fcba412f65 (patch)
tree1e043fb597ef29943ab94e70fad8ce9e38929c4f /sys-apps/man-pages-posix/man-pages-posix-2017a-r1.ebuild
parentfc32d443f6a2e4d05c712c050bb74e8f79f4af1f (diff)
gentoo auto-resync : 19:09:2022 - 11:21:41
Diffstat (limited to 'sys-apps/man-pages-posix/man-pages-posix-2017a-r1.ebuild')
-rw-r--r--sys-apps/man-pages-posix/man-pages-posix-2017a-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/man-pages-posix/man-pages-posix-2017a-r1.ebuild b/sys-apps/man-pages-posix/man-pages-posix-2017a-r1.ebuild
new file mode 100644
index 000000000000..2fc43800f7ef
--- /dev/null
+++ b/sys-apps/man-pages-posix/man-pages-posix-2017a-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}-${PV:0:4}-${PV:0-1}"
+DESCRIPTION="POSIX man-pages (0p, 1p, 3p)"
+HOMEPAGE="https://www.kernel.org/doc/man-pages/"
+SRC_URI="https://www.kernel.org/pub/linux/docs/man-pages/${PN}/${MY_P}.tar.xz"
+
+LICENSE="freedist" # to be clarified, see bug 871636
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE=""
+RESTRICT="binchecks"
+
+RDEPEND="virtual/man !<sys-apps/man-pages-3"
+
+S="${WORKDIR}/${PN}-${PV:0:4}"
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ emake install DESTDIR="${ED}"
+ dodoc man-pages-*.Announce README
+}