summaryrefslogtreecommitdiff
path: root/sys-apps/lshw/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /sys-apps/lshw/files
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'sys-apps/lshw/files')
-rw-r--r--sys-apps/lshw/files/lshw-02.18b-gentoo.patch161
-rw-r--r--sys-apps/lshw/files/lshw-02.18b-gettext-array.patch31
-rw-r--r--sys-apps/lshw/files/lshw-02.18b-sgx.patch32
3 files changed, 0 insertions, 224 deletions
diff --git a/sys-apps/lshw/files/lshw-02.18b-gentoo.patch b/sys-apps/lshw/files/lshw-02.18b-gentoo.patch
deleted file mode 100644
index dd42df9b5282..000000000000
--- a/sys-apps/lshw/files/lshw-02.18b-gentoo.patch
+++ /dev/null
@@ -1,161 +0,0 @@
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -21,11 +21,11 @@
- CXX?=c++
- INCLUDES=-I./core/
- DEFINES=-DPREFIX=\"$(PREFIX)\" -DSBINDIR=\"$(SBINDIR)\" -DMANDIR=\"$(MANDIR)\" -DDATADIR=\"$(DATADIR)\"
--CXXFLAGS=-g -Wall -g $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
-+CXXFLAGS += -Wall $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
- ifeq ($(SQLITE), 1)
- CXXFLAGS+= -DSQLITE $(shell pkg-config --cflags sqlite3)
- endif
--LDFLAGS=-L./core/ -g
-+LDFLAGS += -L./core/
- ifneq ($(shell $(LD) --help 2| grep -- --as-needed), )
- LDFLAGS+= -Wl,--as-needed
- endif
-@@ -39,27 +39,25 @@
- export LIBS
- export LDFLAGS
-
--DATAFILES = pci.ids usb.ids oui.txt manuf.txt
--
--all: $(PACKAGENAME) $(PACKAGENAME).1 $(DATAFILES)
-+all: $(PACKAGENAME) $(PACKAGENAME).1
-
- .cc.o:
- $(CXX) $(CXXFLAGS) -c $< -o $@
-
- .PHONY: core
- core:
-- +make -C core all
-+ $(MAKE) -C core all
-
- $(PACKAGENAME): core $(PACKAGENAME).o
- $(CXX) $(LDFLAGS) -o $@ $(PACKAGENAME).o $(LIBS)
-
- .PHONY: po
- po:
-- +make -C po all
-+ $(MAKE) -C po all
-
- .PHONY: gui
- gui: core
-- +make -C gui all
-+ $(MAKE) -C gui all
-
- .PHONY: nologo
- nologo:
-@@ -70,7 +68,6 @@
-
- $(PACKAGENAME)-static: core core/lib$(PACKAGENAME).a $(PACKAGENAME).o
- $(CXX) $(LDSTATIC) $(LDFLAGS) -o $@ $(PACKAGENAME).o $(LIBS)
-- $(STRIP) $@
-
- .PHONY: compressed
- compressed: $(PACKAGENAME)-compressed
-@@ -93,14 +90,13 @@
- manuf.txt:
- wget -O $@ http://anonsvn.wireshark.org/wireshark/trunk/manuf
-
--install: all
-+install:
- $(INSTALL) -d -m 0755 $(DESTDIR)/$(SBINDIR)
- $(INSTALL) -m 0755 $(PACKAGENAME) $(DESTDIR)/$(SBINDIR)
- $(INSTALL) -d -m 0755 $(DESTDIR)/$(MANDIR)/man1
- $(INSTALL) -m 0644 $(PACKAGENAME).1 $(DESTDIR)/$(MANDIR)/man1
- $(INSTALL) -d -m 0755 $(DESTDIR)/$(DATADIR)/$(PACKAGENAME)
-- $(INSTALL) -m 0644 $(DATAFILES) $(DESTDIR)/$(DATADIR)/$(PACKAGENAME)
-- make -C po install
-+ $(MAKE) -C po install
-
- install-gui: gui
- $(INSTALL) -d -m 0755 $(DESTDIR)/$(SBINDIR)
-@@ -112,8 +108,8 @@
-
- clean:
- rm -f $(PACKAGENAME).o $(PACKAGENAME) $(PACKAGENAME)-static $(PACKAGENAME)-compressed
-- make -C core clean
-- make -C gui clean
-+ $(MAKE) -C core clean
-+ $(MAKE) -C gui clean
-
- .timestamp:
- date --utc +%Y%m%d%H%M%S > $@
---- a/src/core/Makefile
-+++ b/src/core/Makefile
-@@ -1,10 +1,9 @@
- PACKAGENAME?=lshw
-
--CXX=c++
-+CXX?=c++
- INCLUDES=
- DEFINES=-DPREFIX=\"$(PREFIX)\" -DSBINDIR=\"$(SBINDIR)\" -DMANDIR=\"$(MANDIR)\" -DDATADIR=\"$(DATADIR)\"
--CXXFLAGS?=-g -Wall $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
--LDFLAGS=
-+CXXFLAGS += -Wall $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
- LDSTATIC=
- LIBS=
-
---- a/src/core/pci.cc
-+++ b/src/core/pci.cc
-@@ -17,7 +17,7 @@
-
- #define PROC_BUS_PCI "/proc/bus/pci"
- #define SYS_BUS_PCI "/sys/bus/pci"
--#define PCIID_PATH DATADIR"/pci.ids:/usr/share/lshw/pci.ids:/usr/local/share/pci.ids:/usr/share/pci.ids:/etc/pci.ids:/usr/share/hwdata/pci.ids:/usr/share/misc/pci.ids"
-+#define PCIID_PATH "/usr/share/misc/pci.ids"
-
- #define PCI_CLASS_REVISION 0x08 /* High 24 bits are class, low 8 revision */
- #define PCI_VENDOR_ID 0x00 /* 16 bits */
---- a/src/core/usb.cc
-+++ b/src/core/usb.cc
-@@ -27,7 +27,7 @@
-
- #define PROCBUSUSBDEVICES "/proc/bus/usb/devices"
- #define SYSKERNELDEBUGUSBDEVICES "/sys/kernel/debug/usb/devices"
--#define USBID_PATH DATADIR"/usb.ids:/usr/share/lshw/usb.ids:/usr/local/share/usb.ids:/usr/share/usb.ids:/etc/usb.ids:/usr/share/hwdata/usb.ids:/usr/share/misc/usb.ids"
-+#define USBID_PATH "/usr/share/misc/usb.ids"
-
- #define USB_CLASS_PER_INTERFACE 0 /* for DeviceClass */
- #define USB_CLASS_AUDIO 1
---- a/src/gui/Makefile
-+++ b/src/gui/Makefile
-@@ -1,5 +1,7 @@
- PACKAGENAME?=lshw
-
-+SQLITE?=0
-+
- CXX?=c++
- CC?=cc
- STRIP?=strip
-@@ -8,14 +10,15 @@
- DEFINES=-DPREFIX=\"$(PREFIX)\" -DSBINDIR=\"$(SBINDIR)\" -DMANDIR=\"$(MANDIR)\" -DDATADIR=\"$(DATADIR)\"
- GTKINCLUDES=$(shell pkg-config gtk+-2.0 --cflags)
- INCLUDES=-I../core $(GTKINCLUDES)
--CXXFLAGS=-g -Wall $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
-+CXXFLAGS += -Wall $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS)
- CFLAGS=$(CXXFLAGS) $(DEFINES)
- GTKLIBS=$(shell pkg-config gtk+-2.0 gmodule-2.0 --libs)
--LIBS=-L../core -llshw -lresolv $(GTKLIBS)
--LDFLAGS=
--ifneq ($(shell $(LD) --help 2| grep -- --as-needed), )
-- LDFLAGS+= -Wl,--as-needed
--endif
-+LIBS=-L../core -llshw -lresolv $(GTKLIBS)
-+
-+ifeq ($(SQLITE), 1)
-+ CXXFLAGS+= -DSQLITE $(shell pkg-config --cflags sqlite3)
-+ LIBS+= $(shell pkg-config --libs sqlite3)
-+endif
-
- OBJS = gtk-lshw.o callbacks.o engine.o print-gui.o stock.o
- SRCS = $(OBJS:.o=.c)
-@@ -39,7 +42,6 @@
- $(CXX) $(LDFLAGS) -o $@ $^ $(LIBS)
-
- install: all
-- $(STRIP) gtk-$(PACKAGENAME)
-
- clean:
- rm -f $(OBJS) gtk-$(PACKAGENAME) gtk-lshw.glade.bak gtk-lshw.gladep.bak callbacks.c.bak callbacks.h.bak Makefile.bak
diff --git a/sys-apps/lshw/files/lshw-02.18b-gettext-array.patch b/sys-apps/lshw/files/lshw-02.18b-gettext-array.patch
deleted file mode 100644
index 4aea6420d7c1..000000000000
--- a/sys-apps/lshw/files/lshw-02.18b-gettext-array.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-patch sent upstream
-
-From 1fb7ebed787ec1b73218c1f12cbb71b103433375 Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Tue, 14 Mar 2017 22:25:12 -0700
-Subject: [PATCH] fix array access with string translations
-
-The code forgot to rebase the num to 0 before indexing the string array.
-It also provides 5 strings, but was only allowing 4 to be accessed.
----
- src/core/dmi.cc | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/core/dmi.cc b/src/core/dmi.cc
-index 250f48572d54..0db074975f2d 100644
---- a/src/core/dmi.cc
-+++ b/src/core/dmi.cc
-@@ -510,8 +510,8 @@ static const char *dmi_memory_array_location(u8 num)
- };
- if (num <= 0x0A)
- return _(memory_array_location[num]);
-- if (num >= 0xA0 && num < 0xA4)
-- return _(jp_memory_array_location[num]);
-+ if (num >= 0xA0 && num <= 0xA4)
-+ return _(jp_memory_array_location[num - 0xA0]);
- return "";
- }
-
---
-2.12.0
-
diff --git a/sys-apps/lshw/files/lshw-02.18b-sgx.patch b/sys-apps/lshw/files/lshw-02.18b-sgx.patch
deleted file mode 100644
index 92bd6c23e2f3..000000000000
--- a/sys-apps/lshw/files/lshw-02.18b-sgx.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-patch from upstream:
-https://ezix.org/src/pkg/lshw/commit/5e5744732b2dcdf83845919256388b3842033183
-
-From 5e5744732b2dcdf83845919256388b3842033183 Mon Sep 17 00:00:00 2001
-From: Wenkai Du <wenkai.du@intel.com>
-Date: Fri, 22 Dec 2017 09:57:57 -0800
-Subject: [PATCH] lshw: fix segmentation fault when /dev/sgx is present
-
-When Intel SGX is enabled in kernel, /dev/sgx is created and is
-picked up by "/dev/sg*" glob matching.
-
-Signed-off-by: Wenkai Du <wenkai.du@intel.com>
----
- src/core/scsi.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/core/scsi.cc b/src/core/scsi.cc
-index b38dda2cd8a8..75061c0fb195 100644
---- a/src/core/scsi.cc
-+++ b/src/core/scsi.cc
-@@ -30,7 +30,7 @@
-
- __ID("@(#) $Id$");
-
--#define SG_X "/dev/sg*"
-+#define SG_X "/dev/sg[0-9]*"
- #define SG_MAJOR 21
-
- #ifndef SCSI_IOCTL_GET_PCI
---
-2.15.1
-