summaryrefslogtreecommitdiff
path: root/sys-apps/logwatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /sys-apps/logwatch
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'sys-apps/logwatch')
-rw-r--r--sys-apps/logwatch/Manifest2
-rw-r--r--sys-apps/logwatch/logwatch-7.5.2.ebuild95
2 files changed, 97 insertions, 0 deletions
diff --git a/sys-apps/logwatch/Manifest b/sys-apps/logwatch/Manifest
index f0a794d20324..eac459a3e624 100644
--- a/sys-apps/logwatch/Manifest
+++ b/sys-apps/logwatch/Manifest
@@ -1,6 +1,8 @@
AUX logwatch 125 BLAKE2B 93e0bb2e65dda3a81e1bf560c06a3739fc2226488492219fab478326e8a05051077cfd6ee604d3ebd7aaa2329687a0f3facdb2741e99bf9ea4207a939a16f885 SHA512 20cdf61fe9e9bfe336c6b7e1f33c982c34e61370431179a2f766da8e1b56f8452c85d75fbba4f459f9c4761a7a932c309d0ba7253aeb6e3b31b220c00106e504
AUX logwatch.tmpfile 39 BLAKE2B 9b1df0ad28bdc16373e71eedb05e8962bf4eda5d564ba8e2632af8158fa3346e8784db2a6bf9aa90c04768743aee6eaefae517feb9f7066d748cae894c1a2299 SHA512 7902aab160b5fd6e1bb1573777f9fab065ed33b0df19da2b5dad31ca962eaea93f9d46e57efca2d76df26c55b48e0578fddf4136e36ed565d8a2b5258dc34afd
DIST logwatch-7.5.1.tar.gz 469715 BLAKE2B 706352c60370d13b4f72047d08965ab0dd36837194a03bf44e08ec43641eddb8d80d655c783d4f25c8fa757853a4e069997b80676b781561c5e0a23b44a393c9 SHA512 945e66192a9e198169426497f7b5167fcbec2af9565dfead728aa91bfdac5f7e1b2ce2f5f404b6f03841fe6b978f70fb969b47d4f60f02f9a8ccea865c5c782c
+DIST logwatch-7.5.2.tar.gz 475277 BLAKE2B e3d841749af4776da84646444dd90bb084dc33712c1a6eeab87d46cb267656527008505f78506168b7ded40f3d0f8209c205249c2f953e6ee8af7a6cd82833d9 SHA512 157486143ba12167f6c50c778372a4295db3744878607bceba8e0813357651bffd8924ef5ef41a4fbd20811c020dcc031eb354a0f52b8eb6d9aac197087c2bc5
EBUILD logwatch-7.5.1.ebuild 2421 BLAKE2B 331cca62555720132abb6370e61a646f948a9cab8c7b8ca586c8e1e31d99d8aa33e9a0b8b47d096f0c9018cfac18e9983b15f582d4fb0eaa9b41d1aacf94d00b SHA512 d16c0c55e425e81652701f9e276bbcef001fd58c91c48269fa1f6db5788ec188c51f2d661e5706aa3a4e5bea27dd5a7e6b986e611008ff3ffd681a6c61e96bc1
+EBUILD logwatch-7.5.2.ebuild 2430 BLAKE2B f0273cf44e1c7abe6059bcc3ce949263a4cadf57e1e84c46b7255be4d64626b1520b45e85762c3b0bd56f5750165762bbb1a15ce1b28a6967c375736be0b3dec SHA512 312d6634eaced0149f9d6a70cc62241f2273dc4476db468e1d71a19dbde7f8ebcd5e542a41c0fce78313b902d1a5858193e5e624016461bf9d5c6e14d5bf8a21
EBUILD logwatch-9999.ebuild 2430 BLAKE2B f0273cf44e1c7abe6059bcc3ce949263a4cadf57e1e84c46b7255be4d64626b1520b45e85762c3b0bd56f5750165762bbb1a15ce1b28a6967c375736be0b3dec SHA512 312d6634eaced0149f9d6a70cc62241f2273dc4476db468e1d71a19dbde7f8ebcd5e542a41c0fce78313b902d1a5858193e5e624016461bf9d5c6e14d5bf8a21
MISC metadata.xml 328 BLAKE2B 623e92420ca1fde8b78ac6142444544897284af5e74b610d2e6cac823b97355fc91bcad0ea3bc7ced3286e1bdf6cc2b340a34143b31529424ba9d90209b7898a SHA512 5feb78397d5abc4fc758c61c2c972032eca10f9fcbdbb6efcbae764c5ab1aaa09fd4f9a31082682dfd8e0ff865147fff22787b8d116bc7a954a4fdc42cf7b3e7
diff --git a/sys-apps/logwatch/logwatch-7.5.2.ebuild b/sys-apps/logwatch/logwatch-7.5.2.ebuild
new file mode 100644
index 000000000000..eefc16389fc7
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-7.5.2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit tmpfiles
+
+PATCHES=()
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/logwatch/git ${PN}"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="http://www.logwatch.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="virtual/cron
+ virtual/mta
+ virtual/mailx
+ dev-lang/perl
+ dev-perl/Date-Calc
+ dev-perl/Date-Manip
+ dev-perl/Tie-IxHash
+ dev-perl/Sys-CPU
+ dev-perl/Sys-MemInfo"
+
+src_install() {
+ dodir /usr/share/logwatch/lib
+ dodir /usr/share/logwatch/scripts/services
+ dodir /usr/share/logwatch/scripts/shared
+ dodir /usr/share/logwatch/default.conf/logfiles
+ dodir /usr/share/logwatch/default.conf/services
+ dodir /usr/share/logwatch/default.conf/html
+ keepdir /etc/logwatch
+
+ # logwatch.pl requires cache dir (bug #607668)
+ newtmpfiles "${FILESDIR}"/logwatch.tmpfile ${PN}.conf
+
+ newsbin scripts/logwatch.pl logwatch.pl
+
+ exeinto /usr/share/logwatch/lib
+ doexe lib/*.pm
+
+ exeinto /usr/share/logwatch/scripts/services
+ doexe scripts/services/*
+
+ exeinto /usr/share/logwatch/scripts/shared
+ doexe scripts/shared/*
+
+ insinto /usr/share/logwatch/default.conf
+ doins conf/logwatch.conf
+
+ insinto /usr/share/logwatch/default.conf/logfiles
+ doins conf/logfiles/*
+
+ insinto /usr/share/logwatch/default.conf/services
+ doins conf/services/*
+
+ insinto /usr/share/logwatch/default.conf/html
+ doins conf/html/*
+
+ # Make sure logwatch is run before anything else #100243
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/logwatch 00-logwatch
+
+ doman logwatch.8
+ dodoc README HOWTO-Customize-LogWatch
+
+ # Do last due to insopts modification.
+ insinto /usr/share/logwatch/scripts/logfiles
+ insopts -m755
+ doins -r scripts/logfiles/*
+}
+
+pkg_postinst() {
+ # Migration from /etc/cron.daily/logwatch -> /etc/cron.daily/00-logwatch (bug #100243)
+ if [[ -e ${ROOT}/etc/cron.daily/logwatch ]] ; then
+ local md5=$(md5sum "${ROOT}"/etc/cron.daily/logwatch)
+ [[ ${md5} == "edb003cbc0686ed4cf37db16025635f3" ]] \
+ && rm -f "${ROOT}"/etc/cron.daily/logwatch \
+ || ewarn "You have two logwatch files in /etc/cron.daily/"
+ fi
+
+ # Trigger cache dir creation to allow immediate use of logwatch (bug #607668)
+ tmpfiles_process ${PN}.conf
+}