summaryrefslogtreecommitdiff
path: root/sys-apps/less/less-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-10 18:21:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-10 18:21:11 +0000
commit1fe49f5b3e13481832866b6b1600741bf3a1f024 (patch)
tree798fe4fb7ef373a92cfafe1a9c5a7954181c7213 /sys-apps/less/less-9999.ebuild
parent79e2fe7ce5d8192f7ddc9f57d4fb11bd1231f041 (diff)
gentoo auto-resync : 10:01:2023 - 18:21:10
Diffstat (limited to 'sys-apps/less/less-9999.ebuild')
-rw-r--r--sys-apps/less/less-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/sys-apps/less/less-9999.ebuild b/sys-apps/less/less-9999.ebuild
index 9add6f6c1d52..afce93c3d215 100644
--- a/sys-apps/less/less-9999.ebuild
+++ b/sys-apps/less/less-9999.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+
WANT_AUTOMAKE=none
WANT_LIBTOOL=none
-if [[ $PV == 9999 ]]; then
+if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/gwsw/less"
inherit git-r3
fi
@@ -21,8 +22,8 @@ MY_PV=${PV/_beta/-beta}
MY_P=${PN}-${MY_PV}
DESCRIPTION="Excellent text file viewer"
HOMEPAGE="http://www.greenwoodsoftware.com/less/"
-[ $PV != 9999 ] && SRC_URI="http://www.greenwoodsoftware.com/less/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P/?beta}
+[[ ${PV} != 9999 ]] && SRC_URI="http://www.greenwoodsoftware.com/less/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P/?beta}
LICENSE="|| ( GPL-3 BSD-2 )"
SLOT="0"
@@ -37,7 +38,7 @@ RDEPEND="${DEPEND}"
src_prepare() {
default
# Per upstream README to prepare live build
- [ $PV == 9999 ] && emake -f Makefile.aut distfiles
+ [[ ${PV} == 9999 ]] && emake -f Makefile.aut distfiles
# Upstream uses unpatched autoconf-2.69, which breaks with clang-16.
# https://bugs.gentoo.org/870412
eautoreconf