summaryrefslogtreecommitdiff
path: root/sys-apps/kmod/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
commit4551b41523452c0d743a71cca34e4dca2ca7538c (patch)
tree2b9ae4a442d7c2810f92833363fd36db073888f0 /sys-apps/kmod/files
parent27e5574c9ed56a2633e25f7fa8f591554266a1b4 (diff)
gentoo auto-resync : 04:01:2023 - 12:06:28
Diffstat (limited to 'sys-apps/kmod/files')
-rw-r--r--sys-apps/kmod/files/kmod-30-configure-clang16.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-apps/kmod/files/kmod-30-configure-clang16.patch b/sys-apps/kmod/files/kmod-30-configure-clang16.patch
new file mode 100644
index 000000000000..a9e1093aecff
--- /dev/null
+++ b/sys-apps/kmod/files/kmod-30-configure-clang16.patch
@@ -0,0 +1,26 @@
+https://github.com/kmod-project/kmod/commit/035e6667d1ace2fd77ef36f5e5d93cd4b1e128a2
+
+From 035e6667d1ace2fd77ef36f5e5d93cd4b1e128a2 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Sat, 17 Dec 2022 17:52:34 +0100
+Subject: [PATCH] kmod: configure.ac: In _Noreturn check, include <stdlib.h>
+ for exit
+
+Otherwise, an implicit functiona declaration is used, causing
+a C99 compatibility issue.
+
+Signed-off-by: Florian Weimer <fweimer@redhat.com>
+Signed-off-by: Lucas De Marchi <lucas.de.marchi@gmail.com>
+--- a/configure.ac
++++ b/configure.ac
+@@ -68,7 +68,8 @@ AC_COMPILE_IFELSE(
+
+ AC_MSG_CHECKING([whether _Noreturn is supported])
+ AC_COMPILE_IFELSE(
+- [AC_LANG_SOURCE([[_Noreturn int foo(void) { exit(0); }]])],
++ [AC_LANG_SOURCE([[#include <stdlib.h>
++ _Noreturn int foo(void) { exit(0); }]])],
+ [AC_DEFINE([HAVE_NORETURN], [1], [Define if _Noreturn is available])
+ AC_MSG_RESULT([yes])],
+ [AC_MSG_RESULT([no])])
+