summaryrefslogtreecommitdiff
path: root/sys-apps/keyutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-07 21:58:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-07 21:58:53 +0000
commitafb0b2f6a3d0dec97ba521230d62d0f9b9e0cd01 (patch)
tree615e36157bca77a49d7a0c35e26b4b5855e3c4cf /sys-apps/keyutils
parenta704e825f55e39189114ffabe2634acee9ec0164 (diff)
gentoo auto-resync : 07:02:2024 - 21:58:53
Diffstat (limited to 'sys-apps/keyutils')
-rw-r--r--sys-apps/keyutils/Manifest1
-rw-r--r--sys-apps/keyutils/keyutils-1.6.3-r1.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/sys-apps/keyutils/Manifest b/sys-apps/keyutils/Manifest
index 322330a36b0c..1bd4892deff0 100644
--- a/sys-apps/keyutils/Manifest
+++ b/sys-apps/keyutils/Manifest
@@ -3,5 +3,6 @@ AUX keyutils-1.5.9-header-extern-c.patch 1154 BLAKE2B df4ecd72145c8634b2ea043e45
AUX keyutils-1.6-makefile-fixup.patch 756 BLAKE2B 8e4e187859933ca4359adff5307bba833cae1a5e4b7c6975fc88e6848ba76ee30e0c59a42ee2110b9874da5db8e60880265f93798abe55f6a12e71346a6b01de SHA512 4becdbc7b1a68b3e6e8e32b2d08005e435f838d02a3406757216717ec82712f181ff0a32397c995b36264469e29cf39fe9311a762e62427f4507f94418c9400b
AUX keyutils-1.6.3-fix-rpmspec-check.patch 1400 BLAKE2B 135c2f9caf216ea57997ea48b6fe0a2546a6f087f39261bb28521c570455d0dd6ce54cd74f007b3cb1611e5ab7e6330513823adba5006151d8fb99d7ac14774c SHA512 8bf8ff09af6f1e763ecfcaff842a9edfbcecaba3e4187805db2ce11d46c789e58133464fb73297934f078a49c2420a010541a6e9c860f3918dc46e1d909bd7d7
DIST keyutils-1.6.3.tar.gz 137022 BLAKE2B b5620b1b6109415fec1268963c2c65d774f3ef7a69eb1ce8d5d8e78b4b807e4fdfda861662a1b5556975ef867add8f985362a31b6608ac2dc198c8d0395d516b SHA512 f65965b8566037078b8eeffa66c6fdbe121c8c2bea7fa5bce04cf7ba5ccc50d5b48e51f4a67ca91e4d5d9a12469e7e3eb3036c920ab25e3feba6e93b4c149cf9
+EBUILD keyutils-1.6.3-r1.ebuild 3554 BLAKE2B a4245996be4bd714fab171faaabfc4d2d2819619bbf1cdf92b9a7214ed760cf13c36aaacd5302a6e2edd14d6eb141fe641878bf14e3a28f9d849b5965b6a9e51 SHA512 2eb4e9000a6ad114c336855948d8c0218c8476f4381a5dedb3c456374c9e14085865f568391dab66154a519b4529213fb8217848222616118028cbad6410406a
EBUILD keyutils-1.6.3.ebuild 3605 BLAKE2B 54d2990ed590550fefb48eac30b4c70a055b48cccfac9842088bc9665e11b75c6b9d1ad2e20546a3598173f0904b270d6059875905a2d01b37884b65cae8133e SHA512 f28d7096302a17cecf956aad5ed6e27905da7b1c5a145ea8cc57d61927361785feb3d50f4ca549a966afea4f385556ccaddce223f7872a512b536533e2401a19
MISC metadata.xml 519 BLAKE2B c0bf6f0d10e2ba0230b8789bb20cd186ac7e01b44038eb01b3461e6bc663ddbb74af569d84477aa058e34e72a65aa12da59f922e83fa019f41ef54ca0137ff88 SHA512 e8b988a0a7b200d5d07822ca136d2532a4dd13c12f019aae27ae1958d93b75fa8f2bf5f05a2f492bb39274eea992e219a1bf0a1c821637859d4da19a50f632fc
diff --git a/sys-apps/keyutils/keyutils-1.6.3-r1.ebuild b/sys-apps/keyutils/keyutils-1.6.3-r1.ebuild
new file mode 100644
index 000000000000..37ead31590a3
--- /dev/null
+++ b/sys-apps/keyutils/keyutils-1.6.3-r1.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs linux-info multilib-minimal
+
+DESCRIPTION="Linux Key Management Utilities"
+HOMEPAGE="https://git.kernel.org/pub/scm/linux/kernel/git/dhowells/keyutils.git"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/dhowells/keyutils.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/1.9"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="!prefix? ( >=sys-kernel/linux-headers-2.6.11 )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6-makefile-fixup.patch
+ "${FILESDIR}"/${PN}-1.5.10-disable-tests.patch #519062 #522050
+ "${FILESDIR}"/${PN}-1.5.9-header-extern-c.patch
+ "${FILESDIR}"/${PN}-1.6.3-fix-rpmspec-check.patch
+)
+
+pkg_setup() {
+ # To prevent a failure in test phase and false positive bug reports
+ # we are enforcing the following options because testsuite expects
+ # that these options are available. I.e. testsuite only decides based
+ # on kernel version which tests will be called, no feature checking.
+ if use test ; then
+ CONFIG_CHECK="KEYS"
+ ERROR_KEYS="You must have CONFIG_KEYS to run the package testsuite!"
+
+ if kernel_is -ge 2 6 10 && kernel_is -lt 4 0 0 ; then
+ CONFIG_CHECK="${CONFIG_CHECK} KEYS_DEBUG_PROC_KEYS"
+ ERROR_KEYS_DEBUG_PROC_KEYS="You must have CONFIG_KEYS_DEBUG_PROC_KEYS to run the package testsuite!"
+ fi
+
+ if kernel_is -ge 4 7 ; then
+ CONFIG_CHECK="${CONFIG_CHECK} KEY_DH_OPERATIONS"
+ ERROR_KEY_DH_OPERATIONS="You must have CONFIG_KEY_DH_OPERATIONS to run the package testsuite!"
+ fi
+ else
+ CONFIG_CHECK="~KEYS"
+ ERROR_KEYS="You will be unable to use this package on this system because CONFIG_KEYS is not set!"
+
+ if kernel_is -ge 4 7 ; then
+ CONFIG_CHECK="${CONFIG_CHECK} ~KEY_DH_OPERATIONS"
+ ERROR_KEY_DH_OPERATIONS="You will be unable to use Diffie-Hellman on this system because CONFIG_KEY_DH_OPERATIONS is not set!"
+ fi
+ fi
+
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # The lsb check is useless, so avoid spurious command not found messages.
+ sed -i -e 's,lsb_release,:,' tests/prepare.inc.sh || die
+ # Some tests call the kernel which calls userspace, but that will
+ # run the install keyutils rather than the locally compiled one,
+ # so disable round trip tests.
+ rm -rf tests/keyctl/requesting/{bad-args,piped,valid}
+
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export AR CC CXX
+ sed -i \
+ -e "1iRPATH = $(usex static -static '')" \
+ -e '/^C.*FLAGS/s|:=|+=|' \
+ -e 's:-Werror::' \
+ -e '/^BUILDFOR/s:=.*:=:' \
+ -e "/^LIBDIR/s:=.*:= /usr/$(get_libdir):" \
+ -e '/^USRLIBDIR/s:=.*:=$(LIBDIR):' \
+ -e "s: /: ${EPREFIX}/:g" \
+ -e '/^NO_ARLIB/d' \
+ Makefile || die
+
+ # We need the static lib in order to statically link programs.
+ if use static ; then
+ export NO_ARLIB=0
+ # Hack the progs to depend on the static lib instead.
+ sed -i \
+ -e '/^.*:.*[$](DEVELLIB)$/s:$(DEVELLIB):$(ARLIB) $(SONAME):' \
+ Makefile || die
+ else
+ export NO_ARLIB=$(usex static-libs 0 1)
+ fi
+ emake
+}
+
+multilib_src_test() {
+ # Execute the locally compiled code rather than the
+ # older versions already installed in the system.
+ LD_LIBRARY_PATH=${BUILD_DIR} \
+ PATH="${BUILD_DIR}:${PATH}" \
+ emake test
+}
+
+multilib_src_install() {
+ # Possibly undo the setting for USE=static (see src_compile).
+ export NO_ARLIB=$(usex static-libs 0 1)
+
+ default
+}
+
+multilib_src_install_all() {
+ dodoc README
+}